Brad Bishop | d7bf8c1 | 2018-02-25 22:55:05 -0500 | [diff] [blame] | 1 | # Copyright (C) 2017 Khem Raj <raj.khem@gmail.com> |
| 2 | # Released under the MIT license (see COPYING.MIT for the terms) |
| 3 | |
| 4 | SUMMARY = "Library containing NIS functions using TI-RPC (IPv6 enabled)" |
| 5 | DESCRIPTION = "This library contains the public client interface for NIS(YP) and NIS+\ |
| 6 | it was part of glibc and now is standalone packages. it also supports IPv6" |
| 7 | HOMEPAGE = "https://github.com/thkukuk/libnsl" |
| 8 | LICENSE = "LGPL-2.1" |
| 9 | LIC_FILES_CHKSUM = "file://COPYING;md5=4fbd65380cdd255951079008b364516c" |
| 10 | SECTION = "libs" |
| 11 | DEPENDS = "libtirpc" |
| 12 | DEPENDS_append_libc-musl = " bsd-headers" |
| 13 | |
| 14 | PV = "1.0.5+git${SRCPV}" |
| 15 | |
| 16 | SRCREV = "dfa2f313524aff9243c4d8ce1bace73786478356" |
| 17 | |
| 18 | SRC_URI = "git://github.com/thkukuk/libnsl \ |
| 19 | file://0001-include-sys-cdefs.h-explicitly.patch \ |
| 20 | file://0002-Define-glibc-specific-macros.patch \ |
| 21 | file://0001-nis_call.c-Include-stdint.h-for-uintptr_t-definition.patch \ |
| 22 | " |
| 23 | |
| 24 | S = "${WORKDIR}/git" |
| 25 | |
| 26 | inherit autotools pkgconfig gettext |
| 27 | |
| 28 | EXTRA_OECONF += "--libdir=${libdir}/nsl --includedir=${includedir}/nsl" |
| 29 | |
| 30 | do_install_append() { |
| 31 | install -d ${D}${libdir} |
| 32 | mv ${D}${libdir}/nsl/pkgconfig ${D}${libdir} |
| 33 | } |
| 34 | |
| 35 | FILES_${PN} += "${libdir}/nsl/*.so.*" |
| 36 | FILES_${PN}-dev += "${includedir}/nsl ${libdir}/nsl/*.so" |
| 37 | FILES_${PN}-staticdev += "${libdir}/nsl/*.a" |