Brad Bishop | 1932369 | 2019-04-05 15:28:33 -0400 | [diff] [blame] | 1 | SUMMARY = "Xfce4 Panel" |
| 2 | SECTION = "x11" |
| 3 | LICENSE = "GPLv2" |
| 4 | LIC_FILES_CHKSUM = "file://COPYING;md5=26a8bd75d8f8498bdbbe64a27791d4ee" |
Brad Bishop | 26bdd44 | 2019-08-16 17:08:17 -0400 | [diff] [blame] | 5 | DEPENDS = "garcon exo gtk+3 cairo virtual/libx11 libxml2 libwnck3 vala-native" |
Brad Bishop | 1932369 | 2019-04-05 15:28:33 -0400 | [diff] [blame] | 6 | |
Brad Bishop | 8410d61 | 2019-11-25 09:40:59 -0500 | [diff] [blame] | 7 | inherit xfce gtk-doc gobject-introspection features_check remove-libtool |
Brad Bishop | 1932369 | 2019-04-05 15:28:33 -0400 | [diff] [blame] | 8 | |
| 9 | REQUIRED_DISTRO_FEATURES = "x11" |
| 10 | |
Brad Bishop | 00ab237 | 2019-10-14 11:06:18 -0400 | [diff] [blame] | 11 | SRC_URI[md5sum] = "3323588f1c18f04891e013243da1e355" |
| 12 | SRC_URI[sha256sum] = "9c3c78b49ddfac7d42a804e6a6ad9d22ad64ec60bbe17d8724bc52d3e3f6d114" |
Brad Bishop | 1932369 | 2019-04-05 15:28:33 -0400 | [diff] [blame] | 13 | SRC_URI += " \ |
| 14 | file://0001-windowmenu-do-not-display-desktop-icon-when-no-windo.patch \ |
Brad Bishop | 00ab237 | 2019-10-14 11:06:18 -0400 | [diff] [blame] | 15 | file://0002-use-lxdm-to-replace-dm-tool.patch \ |
Brad Bishop | 1932369 | 2019-04-05 15:28:33 -0400 | [diff] [blame] | 16 | " |
| 17 | |
| 18 | python populate_packages_prepend() { |
| 19 | plugin_dir = d.expand('${libdir}/xfce4/panel/plugins/') |
| 20 | plugin_name = d.expand('${PN}-plugin-%s') |
| 21 | do_split_packages(d, plugin_dir, '^lib(.*).so$', plugin_name, |
| 22 | '${PN} plugin for %s', extra_depends='', prepend=True, |
| 23 | aux_files_pattern=['${datadir}/xfce4/panel/plugins/%s.desktop', |
| 24 | '${sysconfdir}/xdg/xfce/panel/%s-*', |
| 25 | '${datadir}/icons/hicolor/48x48/apps/*-%s.png', |
| 26 | '${bindir}/*%s*']) |
| 27 | } |
| 28 | |
| 29 | PACKAGES_DYNAMIC += "^${PN}-plugin-.*" |
| 30 | |
| 31 | PACKAGES =+ "${PN}-gtk3" |
| 32 | |
| 33 | FILES_${PN} += "${libdir}/xfce4/panel/migrate \ |
| 34 | ${libdir}/xfce4/panel/wrapper-1.0" |
| 35 | |
| 36 | FILES_${PN}-dev += "${libdir}/xfce4/panel/plugins/*.la" |
| 37 | |
| 38 | FILES_${PN}-gtk3 = " \ |
| 39 | ${libdir}/libxfce4panel-2.0${SOLIBS} \ |
| 40 | ${libdir}/xfce4/panel/wrapper-2.0 \ |
| 41 | " |