Patrick Williams | ac13d5f | 2023-11-24 18:59:46 -0600 | [diff] [blame^] | 1 | # This class is to be inherited by recipes interested in only deploying what is |
| 2 | # listed in the EXTRA_IMAGEDEPENDS. |
| 3 | # It is inheriting the image.bbclass to make sure that the |
| 4 | # image_license.manifest is generated. |
| 5 | |
| 6 | IMAGE_FSTYPES = "" |
| 7 | |
| 8 | inherit image |
| 9 | |
| 10 | IMAGE_FEATURES = "" |
| 11 | EXTRA_IMAGE_FEATURES = "" |
| 12 | |
| 13 | INHIBIT_DEFAULT_DEPS = "1" |
| 14 | DEPENDS = "" |
| 15 | RDEPENDS = "" |
| 16 | RRECOMMENDS = "" |
| 17 | |
| 18 | deltask do_prepare_recipe_sysroot |
| 19 | deltask do_flush_pseudodb |
| 20 | deltask do_image_qa |
| 21 | do_rootfs[depends] = "" |
| 22 | do_rootfs[noexec] = "1" |
| 23 | do_image[noexec] = "1" |
| 24 | do_image_complete[noexec] = "1" |
| 25 | do_build[depends] = "" |