blob: 66c35010b852b01a0e233f039dac4413fd01ab98 [file] [log] [blame]
Patrick Williamsac13d5f2023-11-24 18:59:46 -06001SUMMARY = "Implementation of a fully functional filesystem in a userspace program"
2DESCRIPTION = "FUSE (Filesystem in Userspace) is a simple interface for userspace \
3 programs to export a virtual filesystem to the Linux kernel. FUSE \
4 also aims to provide a secure method for non privileged users to \
5 create and mount their own filesystem implementations. \
6 "
7HOMEPAGE = "https://github.com/libfuse/libfuse"
8SECTION = "libs"
9LICENSE = "GPL-2.0-only & LGPL-2.0-only"
10LIC_FILES_CHKSUM = "file://GPL2.txt;md5=b234ee4d69f5fce4486a80fdaf4a4263 \
11 file://LGPL2.txt;md5=4fbd65380cdd255951079008b364516c \
12 file://LICENSE;md5=a55c12a2d7d742ecb41ca9ae0a6ddc66"
13
14SRC_URI = "https://github.com/libfuse/libfuse/releases/download/fuse-${PV}/fuse-${PV}.tar.gz \
15"
16SRC_URI[sha256sum] = "f797055d9296b275e981f5f62d4e32e089614fc253d1ef2985851025b8a0ce87"
17
18S = "${WORKDIR}/fuse-${PV}"
19
20UPSTREAM_CHECK_URI = "https://github.com/libfuse/libfuse/releases"
21UPSTREAM_CHECK_REGEX = "fuse\-(?P<pver>3(\.\d+)+).tar.xz"
22
23CVE_PRODUCT = "fuse_project:fuse"
24
25inherit meson pkgconfig ptest
26
27SRC_URI += " \
28 file://run-ptest \
29"
30
31RDEPENDS:${PN}-ptest += " \
32 ${PYTHON_PN}-pytest \
33 bash \
34"
35
36do_install_ptest() {
37 install -d ${D}${PTEST_PATH}/test
38 install -d ${D}${PTEST_PATH}/example
39 install -d ${D}${PTEST_PATH}/util
40 cp -rf ${S}/test/* ${D}${PTEST_PATH}/test/
41
42 example_excutables=`find ${B}/example -type f -executable`
43 util_excutables=`find ${B}/util -type f -executable`
44 test_excutables=`find ${B}/test -type f -executable`
45
46 for e in $example_excutables
47 do
48 cp -rf $e ${D}${PTEST_PATH}/example/
49 done
50
51 for e in $util_excutables
52 do
53 cp -rf $e ${D}${PTEST_PATH}/util/
54 done
55
56 for e in $test_excutables
57 do
58 cp -rf $e ${D}${PTEST_PATH}/test
59 done
60}
61
62DEPENDS = "udev"
63
64PACKAGES =+ "fuse3-utils"
65
66RPROVIDES:${PN}-dbg += "fuse3-utils-dbg"
67
68RRECOMMENDS:${PN}:class-target = "kernel-module-fuse fuse3-utils"
69
70FILES:${PN} += "${libdir}/libfuse3.so.*"
71FILES:${PN}-dev += "${libdir}/libfuse3*.la"
72
73# Forbid auto-renaming to libfuse3-utils
74FILES:fuse3-utils = "${bindir} ${base_sbindir}"
75DEBIAN_NOAUTONAME:fuse3-utils = "1"
76DEBIAN_NOAUTONAME:${PN}-dbg = "1"
77
78do_install:append() {
79 rm -rf ${D}${base_prefix}/dev
80}