blob: e28b6ea0182d2cab9a14ad057e1801164a58d200 [file] [log] [blame]
Patrick Williamsac13d5f2023-11-24 18:59:46 -06001DESCRIPTION = "\
2IPC::Run allows you run and interact with child processes \
3using files, pipes, and pseudo-ttys. Both system()-style and scripted \
4usages are supported and may be mixed. Likewise, functional and OO API \
5styles are both supported and may be mixed."
6HOMEPAGE = "https://metacpan.org/release/IPC-Run"
7SECTION = "libs"
8LICENSE = "Artistic-1.0 | GPL-1.0-or-later"
9LIC_FILES_CHKSUM = "file://LICENSE;md5=0ebd37caf53781e8b7223e6b99b63f4e"
10DEPENDS = "perl"
11
12SRC_URI = "git://github.com/toddr/IPC-Run.git;branch=master;protocol=https"
13SRCREV = "ad56c3b5f5a211d32bbb8ac29f180d707ee58c1b"
14
15S = "${WORKDIR}/git"
16
17inherit cpan
18
19EXTRA_CPANFLAGS = "EXPATLIBPATH=${STAGING_LIBDIR} EXPATINCPATH=${STAGING_INCDIR}"
20
21do_compile() {
22 export LIBC="$(find ${STAGING_DIR_TARGET}/${base_libdir}/ -name 'libc-*.so')"
23 cpan_do_compile
24}