Andrew Geissler | 82c905d | 2020-04-13 13:39:40 -0500 | [diff] [blame] | 1 | SUMMARY = "Perl module to manipulate and access gzip files" |
| 2 | DESCRIPTION = "This package contains the gzip.pm module with friends. \ |
| 3 | The module implements perlio layer for gzip." |
| 4 | |
| 5 | HOMEPAGE = "https://metacpan.org/pod/PerlIO::gzip" |
| 6 | SECTION = "libs" |
Andrew Geissler | 9aee500 | 2022-03-30 16:27:02 +0000 | [diff] [blame] | 7 | LICENSE = "Artistic-1.0 | GPL-1.0-or-later" |
Andrew Geissler | 82c905d | 2020-04-13 13:39:40 -0500 | [diff] [blame] | 8 | LIC_FILES_CHKSUM = "file://README;beginline=55;endline=61;md5=bc3da2dec1fbea59ac91172c5e0eb837" |
| 9 | |
| 10 | DEPENDS += "perl" |
| 11 | |
| 12 | SRC_URI = "https://cpan.metacpan.org/authors/id/N/NW/NWCLARK/PerlIO-gzip-${PV}.tar.gz" |
| 13 | |
| 14 | SRC_URI[md5sum] = "0393eae5d0b23df6cf40ed44af7d711c" |
| 15 | SRC_URI[sha256sum] = "4848679a3f201e3f3b0c5f6f9526e602af52923ffa471a2a3657db786bd3bdc5" |
| 16 | |
| 17 | S = "${WORKDIR}/PerlIO-gzip-${PV}" |
| 18 | |
| 19 | EXTRA_CPANFLAGS = "EXPATLIBPATH=${STAGING_LIBDIR} EXPATINCPATH=${STAGING_INCDIR}" |
| 20 | |
| 21 | inherit cpan |
| 22 | |
| 23 | do_compile() { |
| 24 | export LIBC="$(find ${STAGING_DIR_TARGET}/${base_libdir}/ -name 'libc-*.so')" |
| 25 | cpan_do_compile |
| 26 | } |
| 27 | |
Patrick Williams | 213cb26 | 2021-08-07 19:21:33 -0500 | [diff] [blame] | 28 | RDEPENDS:${PN} += "perl perl-module-perlio" |
Andrew Geissler | 82c905d | 2020-04-13 13:39:40 -0500 | [diff] [blame] | 29 | |
| 30 | BBCLASSEXTEND = "native nativesdk" |