Patrick Williams | ac13d5f | 2023-11-24 18:59:46 -0600 | [diff] [blame^] | 1 | SUMMARY = "Reparent a running program to a new terminal" |
| 2 | DESCRIPTION = "reptyr is a utility for taking an existing running program and \ |
| 3 | attaching it to a new terminal. Started a long-running process over ssh, but \ |
| 4 | have to leave and don't want to interrupt it? Just start a screen, use reptyr \ |
| 5 | to grab it, and then kill the ssh session and head on home." |
| 6 | LICENSE = "MIT" |
| 7 | LIC_FILES_CHKSUM = "file://COPYING;md5=25a0555028c71837623fa6dfa4cc45c0" |
| 8 | |
| 9 | SRC_URI = "git://github.com/nelhage/reptyr.git;protocol=https;branch=master" |
| 10 | SRCREV = "1238097fc2cd15db058d2185cc4985daa87bcd41" |
| 11 | |
| 12 | S = "${WORKDIR}/git" |
| 13 | |
| 14 | inherit bash-completion github-releases manpages pkgconfig |
| 15 | |
| 16 | GITHUB_BASE_URI = "https://github.com/nelhage/${BPN}/releases/" |
| 17 | |
| 18 | PACKAGECONFIG ?= "" |
| 19 | PACKAGECONFIG[manpages] = "" |
| 20 | |
| 21 | EXTRA_OEMAKE = "'BINDIR=${bindir}' 'MANDIR=${mandir}' 'PKG_CONFIG=${STAGING_BINDIR_NATIVE}/pkg-config'" |
| 22 | |
| 23 | do_compile () { |
| 24 | oe_runmake |
| 25 | } |
| 26 | |
| 27 | do_install () { |
| 28 | oe_runmake install 'DESTDIR=${D}' |
| 29 | } |