blob: d71f3df004f3d9593ce75dd3df79ddcaf79076aa [file] [log] [blame]
Patrick Williamsac13d5f2023-11-24 18:59:46 -06001SUMMARY = "Async http client/server framework"
2DESCRIPTION = "Asynchronous HTTP client/server framework for asyncio and Python"
3HOMEPAGE = "https://github.com/aio-libs/aiohttp"
4LICENSE = "Apache-2.0"
5LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=748073912af33aa59430d3702aa32d41"
6
7SRC_URI[sha256sum] = "09f23292d29135025e19e8ff4f0a68df078fe4ee013bca0105b2e803989de92d"
8
9PYPI_PACKAGE = "aiohttp"
10inherit python_setuptools_build_meta pypi
11
12RDEPENDS:${PN} = "\
13 ${PYTHON_PN}-async-timeout \
14 ${PYTHON_PN}-attrs \
15 ${PYTHON_PN}-chardet \
16 ${PYTHON_PN}-html \
17 ${PYTHON_PN}-idna-ssl \
18 ${PYTHON_PN}-json \
19 ${PYTHON_PN}-misc \
20 ${PYTHON_PN}-multidict \
21 ${PYTHON_PN}-netserver \
22 ${PYTHON_PN}-typing-extensions \
23 ${PYTHON_PN}-yarl \
24 ${PYTHON_PN}-cchardet \
25 ${PYTHON_PN}-charset-normalizer \
26 ${PYTHON_PN}-aiosignal \
27"