blob: 5cc4291f784cf93fc5f569ddaedd6078b873c7af [file] [log] [blame]
Patrick Williamsac13d5f2023-11-24 18:59:46 -06001SUMMARY = "The asttokens module annotates Python abstract syntax trees (ASTs)"
2HOMEPAGE = "https://github.com/gristlabs/asttokens"
3LICENSE = "Apache-2.0"
4LIC_FILES_CHKSUM = "file://LICENSE;md5=e3fc50a88d0a364313df4b21ef20c29e"
5
6PYPI_PACKAGE = "asttokens"
7
8inherit pypi python_setuptools_build_meta
9
10SRC_URI[sha256sum] = "b03869718ba9a6eb027e134bfdf69f38a236d681c83c160d510768af11254ba0"
11
12DEPENDS += "python3-setuptools-scm-native"
13
14RDEPENDS:${PN} += " \
15 ${PYTHON_PN}-six \
16"
17
18BBCLASSEXTEND = "native"