blob: c01860acd767de367535c13cc3049dd5a3e9d1f3 [file] [log] [blame]
Patrick Williamsac13d5f2023-11-24 18:59:46 -06001SUMMARY = "Python utilities for working with Ethereum ABI definitions, especially encoding and decoding."
2HOMEPAGE = "https://github.com/ethereum/eth-abi"
3SECTION = "devel/python"
4LICENSE = "MIT"
5LIC_FILES_CHKSUM = "file://LICENSE;md5=731f4de9c79bfeba6d8d55f83d0d2423"
6
7SRC_URI[sha256sum] = "60d88788d53725794cdb07c0f0bb0df2a31a6e1ad19644313fe6117ac24eeeb0"
8
9PYPI_PACKAGE = "eth_abi"
10
11inherit pypi setuptools3
12
13RDEPENDS:${PN} += " \
14 python3-eth-typing \
15 python3-eth-utils \
16 python3-parsimonious \
17 python3-setuptools \
18"