Patrick Williams | ac13d5f | 2023-11-24 18:59:46 -0600 | [diff] [blame^] | 1 | SUMMARY = "Python front end for libmagic" |
| 2 | DESCRIPTION = "This library is a Python ctypes interface to libmagic." |
| 3 | HOMEPAGE = "https://darwinsys.com/file/" |
| 4 | LICENSE = "BSD-2-Clause" |
| 5 | SECTION = "devel/python" |
| 6 | LIC_FILES_CHKSUM = "file://LICENSE;md5=0e949c0b3fb4fd86232f00c6ee0bdef3" |
| 7 | |
| 8 | SRC_URI[sha256sum] = "a91d1483117f7ed48cd0238ad9be36b04824d57e9c38ea7523113989e81b9c53" |
| 9 | |
| 10 | PYPI_PACKAGE="file-magic" |
| 11 | |
| 12 | inherit pypi setuptools3 |
| 13 | |
| 14 | RDEPENDS:${PN} += " \ |
| 15 | file \ |
| 16 | ${PYTHON_PN}-core \ |
| 17 | ${PYTHON_PN}-ctypes \ |
| 18 | ${PYTHON_PN}-threading \ |
| 19 | " |
| 20 | |
| 21 | BBCLASSEXTEND = "native nativesdk" |