Patrick Williams | ac13d5f | 2023-11-24 18:59:46 -0600 | [diff] [blame^] | 1 | SUMMARY = "Provides both a high- and low-level interface to the HDF5 library from Python." |
| 2 | HOMEPAGE = "https://www.h5py.org/" |
| 3 | SECTION = "devel/python" |
| 4 | LICENSE = "BSD-3-Clause" |
| 5 | LIC_FILES_CHKSUM = "file://LICENSE;md5=113251d71fb0384712c719b567261c5c" |
| 6 | |
| 7 | SRC_URI[sha256sum] = "d93adc48ceeb33347eb24a634fb787efc7ae4644e6ea4ba733d099605045c049" |
| 8 | |
| 9 | SRC_URI += "file://0001-setup_build.py-avoid-absolute-path.patch" |
| 10 | |
| 11 | inherit pkgconfig pypi setuptools3 |
| 12 | |
| 13 | BBCLASSEXTEND = "native" |
| 14 | |
| 15 | DEPENDS = "python3-pkgconfig-native \ |
| 16 | python3-cython-native \ |
| 17 | python3-numpy-native \ |
| 18 | python3-six-native \ |
| 19 | hdf5-native \ |
| 20 | python3 \ |
| 21 | hdf5 \ |
| 22 | " |
| 23 | |
| 24 | PACKAGESPLITFUNCS =+ "fix_cythonized_sources" |
| 25 | |
| 26 | fix_cythonized_sources() { |
| 27 | for f in `grep -l -r -e '\/* Generated by Cython.*/$' ${PKGD}${TARGET_DBGSRC_DIR}`; do |
| 28 | if [ -e $f ]; then |
| 29 | sed -i -e 's#${RECIPE_SYSROOT_NATIVE}##g' $f |
| 30 | fi |
| 31 | done |
| 32 | } |
| 33 | |
| 34 | RDEPENDS:${PN} = "python3-numpy \ |
| 35 | python3-six \ |
| 36 | python3-json \ |
| 37 | " |
| 38 | |
| 39 | export HDF5_VERSION="1.14.0" |