blob: 322c90eda5d4e5261e07080509f940e016a0fb69 [file] [log] [blame]
Patrick Williamsac13d5f2023-11-24 18:59:46 -06001SUMMARY = "Python Imaging Library (Fork). Pillow is the friendly PIL fork by Alex \
2Clark and Contributors. PIL is the Python Imaging Library by Fredrik Lundh and \
3Contributors."
4HOMEPAGE = "https://pillow.readthedocs.io"
5LICENSE = "MIT"
6LIC_FILES_CHKSUM = "file://LICENSE;md5=b22dc6b663b9175820e5e03337c7596b"
7
8SRC_URI = "git://github.com/python-pillow/Pillow.git;branch=10.0.x;protocol=https \
9 file://0001-support-cross-compiling.patch \
10 file://0001-explicitly-set-compile-options.patch \
11 file://run-ptest \
12 "
13SRCREV ?= "da59ad000d1405eaecd557175e29083a87d19f7c"
14
15inherit setuptools3 ptest
16
17PIP_INSTALL_PACKAGE = "Pillow"
18PIP_INSTALL_DIST_PATH = "${S}/dist"
19
20DEPENDS += " \
21 zlib \
22 jpeg \
23 tiff \
24 freetype \
25 lcms \
26 openjpeg \
27"
28
29RDEPENDS:${PN} += " \
30 ${PYTHON_PN}-misc \
31 ${PYTHON_PN}-logging \
32 ${PYTHON_PN}-numbers \
33 ${@bb.utils.contains('DISTRO_FEATURES', 'x11', 'libxcb', '', d)} \
34"
35
36RDEPENDS:${PN}-ptest += " \
37 bash \
38 ghostscript \
39 jpeg-tools \
40 libwebp \
41 ${PYTHON_PN}-core \
42 ${PYTHON_PN}-distutils \
43 ${PYTHON_PN}-image \
44 ${PYTHON_PN}-mmap \
45 ${PYTHON_PN}-pytest \
46 ${PYTHON_PN}-pytest-timeout \
47 ${PYTHON_PN}-resource \
48 ${PYTHON_PN}-unixadmin\
49 ${@bb.utils.contains('DISTRO_FEATURES', 'x11', 'tk', '', d)} \
50"
51
52CVE_PRODUCT = "pillow"
53
54S = "${WORKDIR}/git"
55
56RPROVIDES:${PN} += "python3-imaging"
57
58do_install_ptest() {
59 install -d ${D}${PTEST_PATH}/Tests
60 cp -rf ${S}/Tests ${D}${PTEST_PATH}/
61}
62
63BBCLASSEXTEND = "native"
64
65SRCREV = "e34d346f10c0b1c814661e662a3e0c1ef084cf1c"