Patrick Williams | ac13d5f | 2023-11-24 18:59:46 -0600 | [diff] [blame^] | 1 | SUMMARY = "A small Python module for determining appropriate platform-specific dirs" |
| 2 | HOMEPAGE = "https://github.com/platformdirs/platformdirs" |
| 3 | LICENSE = "BSD-3-Clause" |
| 4 | LIC_FILES_CHKSUM = "file://LICENSE;md5=ea4f5a41454746a9ed111e3d8723d17a" |
| 5 | |
| 6 | SRC_URI += " \ |
| 7 | file://run-ptest \ |
| 8 | " |
| 9 | |
| 10 | SRC_URI[sha256sum] = "cb633b2bcf10c51af60beb0ab06d2f1d69064b43abf4c185ca6b28865f3f9731" |
| 11 | |
| 12 | inherit pypi python_hatchling ptest |
| 13 | |
| 14 | DEPENDS += " \ |
| 15 | ${PYTHON_PN}-hatch-vcs-native \ |
| 16 | " |
| 17 | |
| 18 | RDEPENDS:${PN}-ptest += " \ |
| 19 | ${PYTHON_PN}-appdirs \ |
| 20 | ${PYTHON_PN}-covdefaults \ |
| 21 | ${PYTHON_PN}-pytest \ |
| 22 | ${PYTHON_PN}-pytest-mock \ |
| 23 | ${PYTHON_PN}-pytest-cov \ |
| 24 | " |
| 25 | |
| 26 | do_install_ptest() { |
| 27 | install -d ${D}${PTEST_PATH} |
| 28 | cp -rf ${S}/tests ${D}${PTEST_PATH}/ |
| 29 | } |
| 30 | |
| 31 | BBCLASSEXTEND = "native nativesdk" |