Patrick Williams | ac13d5f | 2023-11-24 18:59:46 -0600 | [diff] [blame^] | 1 | SUMMARY = "A Python implementation of Google's Encoded Polyline Algorithm Format" |
| 2 | HOMEPAGE = "https://github.com/frederickjansen/polyline" |
| 3 | LICENSE = "MIT" |
| 4 | LIC_FILES_CHKSUM = "file://LICENSE;md5=1fb8d1dc685695195bb3c1e48adfef48" |
| 5 | |
| 6 | SRC_URI[sha256sum] = "74cb5cea098dddf09d1a5a1f17af9184d371cbf3e9723de0194e530ec39ca1f6" |
| 7 | |
| 8 | inherit pypi python_setuptools_build_meta ptest |
| 9 | |
| 10 | RDEPENDS:${PN} += "python3-six" |
| 11 | |
| 12 | BBCLASSEXTEND = "native nativesdk" |
| 13 | |
| 14 | SRC_URI += " \ |
| 15 | file://run-ptest \ |
| 16 | " |
| 17 | |
| 18 | RDEPENDS:${PN}-ptest += " \ |
| 19 | ${PYTHON_PN}-pytest \ |
| 20 | " |
| 21 | |
| 22 | do_install_ptest() { |
| 23 | install -d ${D}${PTEST_PATH}/test |
| 24 | cp -rf ${S}/tests/* ${D}${PTEST_PATH}/test/ |
| 25 | } |