Patrick Williams | ac13d5f | 2023-11-24 18:59:46 -0600 | [diff] [blame^] | 1 | SUMMARY = "Python interface for c-ares" |
| 2 | DESCRIPTION = "\ |
| 3 | pycares is a Python module which provides an interface to c-ares. c-ares is \ |
| 4 | a C library that performs DNS requests and name resolutions asynchronously." |
| 5 | HOMEPAGE = "https://github.com/saghul/pycares" |
| 6 | LICENSE = "MIT" |
| 7 | LIC_FILES_CHKSUM = "file://LICENSE;md5=b1538fcaea82ebf2313ed648b96c69b1" |
| 8 | |
| 9 | SRC_URI[sha256sum] = "f47579d508f2f56eddd16ce72045782ad3b1b3b678098699e2b6a1b30733e1c2" |
| 10 | |
| 11 | PYPI_PACKAGE = "pycares" |
| 12 | |
| 13 | inherit pypi setuptools3 |
| 14 | |
| 15 | DEPENDS += "${PYTHON_PN}-cffi-native" |
| 16 | |
| 17 | RDEPENDS:${PN} += " \ |
| 18 | ${PYTHON_PN}-cffi \ |
| 19 | ${PYTHON_PN}-idna \ |
| 20 | " |