blob: d31f45131f87772c57ea22bb639386c1c566301f [file] [log] [blame]
Patrick Williamsac13d5f2023-11-24 18:59:46 -06001SUMMARY = "Python bindings for interacting with systemd over DBus"
2LICENSE = "LGPL-2.1-only"
3LIC_FILES_CHKSUM = "file://LICENSE;md5=4fbd65380cdd255951079008b364516c"
4
5SRC_URI[sha256sum] = "4dcfa4b13a55685c49d3d17c10631eca18c33770f66316f8ef2337b8951cc144"
6
7DEPENDS = "systemd python3-cython-native"
8RDEPENDS:${PN} += "\
9 ${PYTHON_PN}-xml \
10 ${PYTHON_PN}-lxml \
11 ${PYTHON_PN}-pprint \
12 ${PYTHON_PN}-core \
13 ${PYTHON_PN}-shell \
14 ${PYTHON_PN}-io \
15"
16REQUIRED_DISTRO_FEATURES = "systemd"
17
18inherit pypi setuptools3 features_check pkgconfig
19
20do_configure:prepend() {
21 rm -rf ${S}/pystemd/*.c
22}
23
24BBCLASSEXTEND = "native"