blob: 1623f721fc1f15078445804af48df24e56dfe8d2 [file] [log] [blame]
Patrick Williamsac13d5f2023-11-24 18:59:46 -06001SUMMARY = "Python wrapper around rapidjson"
2HOMEPAGE = "https://github.com/python-rapidjson/python-rapidjson"
3
4LICENSE = "MIT"
5LIC_FILES_CHKSUM = "file://LICENSE;md5=4daf3929156304df67003c33274a98bd"
6
7SRC_URI = "git://github.com/python-rapidjson/python-rapidjson.git;protocol=https;branch=master"
8SRCREV = "a87053d9b97750afddb504da05bd1cd9f4b94654"
9
10S = "${WORKDIR}/git"
11
12# Inheriting ptest provides functionality for packaging and installing runtime tests for this recipe
13inherit setuptools3 ptest
14
15SETUPTOOLS_BUILD_ARGS += " --rj-include-dir=${RECIPE_SYSROOT}${includedir}"
16
17# run-ptest is a shell script that starts the test suite
18SRC_URI += " \
19 file://run-ptest \
20"
21
22DEPENDS += " \
23 rapidjson \
24"
25
26# Adding required python package for the ptest (pytest and pytest->automake report translation)
27RDEPENDS:${PN}-ptest += " \
28 ${PYTHON_PN}-pytest \
29 ${PYTHON_PN}-unittest-automake-output \
30 ${PYTHON_PN}-pytz \
31"
32
33RDEPENDS:${PN} += " \
34 ${PYTHON_PN}-core \
35"
36
37# Installing the test suite on the target
38do_install_ptest() {
39 install -d ${D}${PTEST_PATH}/tests
40 cp -rf ${S}/tests/* ${D}${PTEST_PATH}/tests/
41}