Patrick Williams | ac13d5f | 2023-11-24 18:59:46 -0600 | [diff] [blame^] | 1 | SUMMARY = "Python wrapper around rapidjson" |
| 2 | HOMEPAGE = "https://github.com/python-rapidjson/python-rapidjson" |
| 3 | |
| 4 | LICENSE = "MIT" |
| 5 | LIC_FILES_CHKSUM = "file://LICENSE;md5=4daf3929156304df67003c33274a98bd" |
| 6 | |
| 7 | SRC_URI = "git://github.com/python-rapidjson/python-rapidjson.git;protocol=https;branch=master" |
| 8 | SRCREV = "a87053d9b97750afddb504da05bd1cd9f4b94654" |
| 9 | |
| 10 | S = "${WORKDIR}/git" |
| 11 | |
| 12 | # Inheriting ptest provides functionality for packaging and installing runtime tests for this recipe |
| 13 | inherit setuptools3 ptest |
| 14 | |
| 15 | SETUPTOOLS_BUILD_ARGS += " --rj-include-dir=${RECIPE_SYSROOT}${includedir}" |
| 16 | |
| 17 | # run-ptest is a shell script that starts the test suite |
| 18 | SRC_URI += " \ |
| 19 | file://run-ptest \ |
| 20 | " |
| 21 | |
| 22 | DEPENDS += " \ |
| 23 | rapidjson \ |
| 24 | " |
| 25 | |
| 26 | # Adding required python package for the ptest (pytest and pytest->automake report translation) |
| 27 | RDEPENDS:${PN}-ptest += " \ |
| 28 | ${PYTHON_PN}-pytest \ |
| 29 | ${PYTHON_PN}-unittest-automake-output \ |
| 30 | ${PYTHON_PN}-pytz \ |
| 31 | " |
| 32 | |
| 33 | RDEPENDS:${PN} += " \ |
| 34 | ${PYTHON_PN}-core \ |
| 35 | " |
| 36 | |
| 37 | # Installing the test suite on the target |
| 38 | do_install_ptest() { |
| 39 | install -d ${D}${PTEST_PATH}/tests |
| 40 | cp -rf ${S}/tests/* ${D}${PTEST_PATH}/tests/ |
| 41 | } |