blob: aa11534f7db0d8a43832ea854b085b8f8ce7573c [file] [log] [blame]
Patrick Williamsac13d5f2023-11-24 18:59:46 -06001# SPDX-License-Identifier: MIT
2# Copyright (C) 2023 iris-GmbH infrared & intelligent sensors
3
4SUMMARY = "A tool for creating isolated virtual python environments."
5HOMEPAGE = "https://github.com/pypa/virtualenv"
6LICENSE = "MIT"
7LIC_FILES_CHKSUM = "file://LICENSE;md5=0ce089158cf60a8ab6abb452b6405538"
8
9SRC_URI[sha256sum] = "02ece4f56fbf939dbbc33c0715159951d6bf14aaf5457b092e4548e1382455af"
10
11BBCLASSEXTEND = "native nativesdk"
12inherit pypi python_hatchling
13
14DEPENDS += "\
15 ${PYTHON_PN}-hatch-vcs-native \
16"
17
18RDEPENDS:${PN} += " \
19 ${PYTHON_PN}-distlib \
20 ${PYTHON_PN}-filelock \
21 ${PYTHON_PN}-platformdirs \
22"