Patrick Williams | ac13d5f | 2023-11-24 18:59:46 -0600 | [diff] [blame^] | 1 | SUMMARY = "Debugging and profiling extension for PHP" |
| 2 | LICENSE = "Xdebug" |
| 3 | LIC_FILES_CHKSUM = "file://LICENSE;md5=92d94a330d34ee6edc2638450736f119" |
| 4 | |
| 5 | DEPENDS = "php re2c-native" |
| 6 | |
| 7 | SRC_URI = "http://xdebug.org/files/xdebug-${PV}.tgz" |
| 8 | |
| 9 | SRC_URI[sha256sum] = "f48777371f90cbb315ea4ea082a1ede6765bcfb35d7d6356ab8f71fd6dfcc157" |
| 10 | |
| 11 | UPSTREAM_CHECK_REGEX = "xdebug-(?P<pver>\d+(\.\d+)+)\.tgz" |
| 12 | |
| 13 | inherit autotools |
| 14 | |
| 15 | EXTRA_OECONF += "--enable-xdebug -with-php-config=${STAGING_BINDIR_CROSS}/php-config" |
| 16 | |
| 17 | do_configure() { |
| 18 | cd ${S} |
| 19 | ${STAGING_BINDIR_CROSS}/phpize |
| 20 | cd ${B} |
| 21 | |
| 22 | # Running autoreconf as autotools_do_configure would do here |
| 23 | # breaks the libtool configuration resulting in a failure later |
| 24 | # in do_compile. It's possible this may be fixable, however the |
| 25 | # easiest course of action for the moment is to avoid doing that. |
| 26 | oe_runconf |
| 27 | } |
| 28 | |
| 29 | do_install() { |
| 30 | oe_runmake install INSTALL_ROOT=${D} |
| 31 | } |
| 32 | |
| 33 | FILES:${PN} += "${libdir}/php*/extensions/*/*.so" |
| 34 | FILES:${PN}-dbg += "${libdir}/php*/extensions/*/.debug" |