Andrew Geissler | 517393d | 2023-01-13 08:55:19 -0600 | [diff] [blame] | 1 | HOMEPAGE = "http://mesonbuild.com" |
| 2 | SUMMARY = "A high performance build system" |
| 3 | DESCRIPTION = "Meson is a build system designed to increase programmer \ |
| 4 | productivity. It does this by providing a fast, simple and easy to use \ |
| 5 | interface for modern software development tools and practices." |
| 6 | |
| 7 | LICENSE = "Apache-2.0" |
| 8 | LIC_FILES_CHKSUM = "file://COPYING;md5=3b83ef96387f14655fc854ddc3c6bd57" |
| 9 | |
| 10 | GITHUB_BASE_URI = "https://github.com/mesonbuild/meson/releases/" |
| 11 | SRC_URI = "${GITHUB_BASE_URI}/download/${PV}/meson-${PV}.tar.gz \ |
| 12 | file://meson-setup.py \ |
| 13 | file://meson-wrapper \ |
| 14 | file://0001-python-module-do-not-manipulate-the-environment-when.patch \ |
Andrew Geissler | 517393d | 2023-01-13 08:55:19 -0600 | [diff] [blame] | 15 | file://0001-Make-CPU-family-warnings-fatal.patch \ |
| 16 | file://0002-Support-building-allarch-recipes-again.patch \ |
Andrew Geissler | 517393d | 2023-01-13 08:55:19 -0600 | [diff] [blame] | 17 | " |
Andrew Geissler | 2013739 | 2023-10-12 04:59:14 -0600 | [diff] [blame] | 18 | SRC_URI[sha256sum] = "4a0f04de331fbc7af3b802a844fc8838f4ccd1ded1e792ba4f8f2faf8c5fe4d6" |
Andrew Geissler | 517393d | 2023-01-13 08:55:19 -0600 | [diff] [blame] | 19 | |
| 20 | inherit python_setuptools_build_meta github-releases |
| 21 | |
| 22 | RDEPENDS:${PN} = "ninja python3-modules python3-pkg-resources" |
| 23 | |
| 24 | FILES:${PN} += "${datadir}/polkit-1" |
| 25 | |
| 26 | do_install:append () { |
| 27 | # As per the same issue in the python recipe itself: |
| 28 | # Unfortunately the following pyc files are non-deterministc due to 'frozenset' |
| 29 | # being written without strict ordering, even with PYTHONHASHSEED = 0 |
| 30 | # Upstream is discussing ways to solve the issue properly, until then let's |
| 31 | # just not install the problematic files. |
| 32 | # More info: http://benno.id.au/blog/2013/01/15/python-determinism |
Andrew Geissler | 5082cc7 | 2023-09-11 08:41:39 -0400 | [diff] [blame] | 33 | rm -f ${D}${libdir}/python*/site-packages/mesonbuild/dependencies/__pycache__/mpi.cpython* |
Andrew Geissler | 517393d | 2023-01-13 08:55:19 -0600 | [diff] [blame] | 34 | } |
| 35 | |
| 36 | BBCLASSEXTEND = "native nativesdk" |
| 37 | |
| 38 | inherit meson-routines |
| 39 | |
| 40 | # The cross file logic is similar but not identical to that in meson.bbclass, |
| 41 | # since it's generating for an SDK rather than a cross-compile. Important |
| 42 | # differences are: |
| 43 | # - We can't set vars like CC, CXX, etc. yet because they will be filled in with |
| 44 | # real paths by meson-setup.sh when the SDK is extracted. |
| 45 | # - Some overrides aren't needed, since the SDK injects paths that take care of |
| 46 | # them. |
| 47 | def var_list2str(var, d): |
| 48 | items = d.getVar(var).split() |
| 49 | return items[0] if len(items) == 1 else ', '.join(repr(s) for s in items) |
| 50 | |
| 51 | def generate_native_link_template(d): |
| 52 | val = ['-L@{OECORE_NATIVE_SYSROOT}${libdir_native}', |
| 53 | '-L@{OECORE_NATIVE_SYSROOT}${base_libdir_native}', |
| 54 | '-Wl,-rpath-link,@{OECORE_NATIVE_SYSROOT}${libdir_native}', |
| 55 | '-Wl,-rpath-link,@{OECORE_NATIVE_SYSROOT}${base_libdir_native}', |
| 56 | '-Wl,--allow-shlib-undefined' |
| 57 | ] |
| 58 | build_arch = d.getVar('BUILD_ARCH') |
| 59 | if 'x86_64' in build_arch: |
| 60 | loader = 'ld-linux-x86-64.so.2' |
| 61 | elif 'i686' in build_arch: |
| 62 | loader = 'ld-linux.so.2' |
| 63 | elif 'aarch64' in build_arch: |
| 64 | loader = 'ld-linux-aarch64.so.1' |
| 65 | elif 'ppc64le' in build_arch: |
| 66 | loader = 'ld64.so.2' |
Patrick Williams | 864cc43 | 2023-02-09 14:54:44 -0600 | [diff] [blame] | 67 | elif 'loongarch64' in build_arch: |
| 68 | loader = 'ld-linux-loongarch-lp64d.so.1' |
Patrick Williams | ac13d5f | 2023-11-24 18:59:46 -0600 | [diff] [blame^] | 69 | elif 'riscv64' in build_arch: |
| 70 | loader = 'ld-linux-riscv64-lp64d.so.1' |
Andrew Geissler | 517393d | 2023-01-13 08:55:19 -0600 | [diff] [blame] | 71 | |
| 72 | if loader: |
| 73 | val += ['-Wl,--dynamic-linker=@{OECORE_NATIVE_SYSROOT}${base_libdir_native}/' + loader] |
| 74 | |
| 75 | return repr(val) |
| 76 | |
| 77 | install_templates() { |
| 78 | install -d ${D}${datadir}/meson |
| 79 | |
| 80 | cat >${D}${datadir}/meson/meson.native.template <<EOF |
| 81 | [binaries] |
| 82 | c = ${@meson_array('BUILD_CC', d)} |
| 83 | cpp = ${@meson_array('BUILD_CXX', d)} |
| 84 | ar = ${@meson_array('BUILD_AR', d)} |
| 85 | nm = ${@meson_array('BUILD_NM', d)} |
| 86 | strip = ${@meson_array('BUILD_STRIP', d)} |
| 87 | readelf = ${@meson_array('BUILD_READELF', d)} |
| 88 | pkgconfig = 'pkg-config-native' |
| 89 | |
| 90 | [built-in options] |
| 91 | c_args = ['-isystem@{OECORE_NATIVE_SYSROOT}${includedir_native}' , ${@var_list2str('BUILD_OPTIMIZATION', d)}] |
| 92 | c_link_args = ${@generate_native_link_template(d)} |
| 93 | cpp_args = ['-isystem@{OECORE_NATIVE_SYSROOT}${includedir_native}' , ${@var_list2str('BUILD_OPTIMIZATION', d)}] |
| 94 | cpp_link_args = ${@generate_native_link_template(d)} |
| 95 | [properties] |
| 96 | sys_root = '@OECORE_NATIVE_SYSROOT' |
| 97 | EOF |
| 98 | |
| 99 | cat >${D}${datadir}/meson/meson.cross.template <<EOF |
| 100 | [binaries] |
| 101 | c = @CC |
| 102 | cpp = @CXX |
| 103 | ar = @AR |
| 104 | nm = @NM |
| 105 | strip = @STRIP |
| 106 | pkgconfig = 'pkg-config' |
| 107 | |
| 108 | [built-in options] |
| 109 | c_args = @CFLAGS |
| 110 | c_link_args = @LDFLAGS |
| 111 | cpp_args = @CPPFLAGS |
| 112 | cpp_link_args = @LDFLAGS |
| 113 | |
| 114 | [properties] |
| 115 | needs_exe_wrapper = true |
| 116 | sys_root = @OECORE_TARGET_SYSROOT |
| 117 | |
| 118 | [host_machine] |
| 119 | system = '$host_system' |
| 120 | cpu_family = '$host_cpu_family' |
| 121 | cpu = '$host_cpu' |
| 122 | endian = '$host_endian' |
| 123 | EOF |
| 124 | } |
| 125 | |
| 126 | do_install:append:class-nativesdk() { |
| 127 | host_system=${SDK_OS} |
| 128 | host_cpu_family=${@meson_cpu_family("SDK_ARCH", d)} |
| 129 | host_cpu=${SDK_ARCH} |
| 130 | host_endian=${@meson_endian("SDK", d)} |
| 131 | install_templates |
| 132 | |
| 133 | install -d ${D}${SDKPATHNATIVE}/post-relocate-setup.d |
| 134 | install -m 0755 ${WORKDIR}/meson-setup.py ${D}${SDKPATHNATIVE}/post-relocate-setup.d/ |
| 135 | |
| 136 | # We need to wrap the real meson with a thin env setup wrapper. |
| 137 | mv ${D}${bindir}/meson ${D}${bindir}/meson.real |
| 138 | install -m 0755 ${WORKDIR}/meson-wrapper ${D}${bindir}/meson |
| 139 | } |
| 140 | |
| 141 | FILES:${PN}:append:class-nativesdk = "${datadir}/meson ${SDKPATHNATIVE}" |
| 142 | |
| 143 | do_install:append:class-native() { |
| 144 | host_system=${HOST_OS} |
| 145 | host_cpu_family=${@meson_cpu_family("HOST_ARCH", d)} |
| 146 | host_cpu=${HOST_ARCH} |
| 147 | host_endian=${@meson_endian("HOST", d)} |
| 148 | install_templates |
| 149 | |
| 150 | install -d ${D}${datadir}/post-relocate-setup.d |
| 151 | install -m 0755 ${WORKDIR}/meson-setup.py ${D}${datadir}/post-relocate-setup.d/ |
| 152 | |
| 153 | # We need to wrap the real meson with a thin wrapper that substitues native/cross files |
| 154 | # when running in a direct SDK environment. |
| 155 | mv ${D}${bindir}/meson ${D}${bindir}/meson.real |
| 156 | install -m 0755 ${WORKDIR}/meson-wrapper ${D}${bindir}/meson |
| 157 | } |