blob: bdba98b8d5757e7b4cfc0f7ada5b7f67d4f795fe [file] [log] [blame]
Patrick Williamsac13d5f2023-11-24 18:59:46 -06001SUMMARY = "The official binary distribution format for Python "
2HOMEPAGE = "https://github.com/pypa/wheel"
3SECTION = "devel/python"
4LICENSE = "MIT"
5LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=7ffb0db04527cfe380e4f2726bd05ebf"
6
7SRC_URI[sha256sum] = "4d4987ce51a49370ea65c0bfd2234e8ce80a12780820d9dc462597a6e60d0841"
8
9inherit python_flit_core pypi
10
11BBCLASSEXTEND = "native nativesdk"
12
13# This used to use the bootstrap install which didn't compile. Until we bump the
14# tmpdir version we can't compile the native otherwise the sysroot unpack fails
15INSTALL_WHEEL_COMPILE_BYTECODE:class-native = "--no-compile-bytecode"