Brad Bishop | 316dfdd | 2018-06-25 12:45:53 -0400 | [diff] [blame] | 1 | SUMMARY = "Tools for managing kernel packet filtering capabilities" |
| 2 | DESCRIPTION = "iptables is the userspace command line program used to configure and control network packet \ |
| 3 | filtering code in Linux." |
| 4 | HOMEPAGE = "http://www.netfilter.org/" |
| 5 | BUGTRACKER = "http://bugzilla.netfilter.org/" |
| 6 | LICENSE = "GPLv2+" |
| 7 | LIC_FILES_CHKSUM = "file://COPYING;md5=b234ee4d69f5fce4486a80fdaf4a4263\ |
| 8 | file://iptables/iptables.c;beginline=13;endline=25;md5=c5cffd09974558cf27d0f763df2a12dc" |
| 9 | |
| 10 | RRECOMMENDS_${PN} = "kernel-module-x-tables \ |
| 11 | kernel-module-ip-tables \ |
| 12 | kernel-module-iptable-filter \ |
| 13 | kernel-module-iptable-nat \ |
| 14 | kernel-module-nf-defrag-ipv4 \ |
| 15 | kernel-module-nf-conntrack \ |
| 16 | kernel-module-nf-conntrack-ipv4 \ |
| 17 | kernel-module-nf-nat \ |
| 18 | kernel-module-ipt-masquerade" |
| 19 | FILES_${PN} =+ "${libdir}/xtables/ ${datadir}/xtables" |
| 20 | |
| 21 | SRC_URI = "http://netfilter.org/projects/iptables/files/iptables-${PV}.tar.bz2 \ |
| 22 | file://0001-configure-Add-option-to-enable-disable-libnfnetlink.patch \ |
| 23 | file://0002-configure.ac-only-check-conntrack-when-libnfnetlink-enabled.patch \ |
| 24 | " |
| 25 | |
| 26 | SRC_URI[md5sum] = "7d2b7847e4aa8832a18437b8a4c1873d" |
| 27 | SRC_URI[sha256sum] = "55d02dfa46263343a401f297d44190f2a3e5113c8933946f094ed40237053733" |
| 28 | |
| 29 | inherit autotools pkgconfig |
| 30 | |
| 31 | EXTRA_OECONF = "--with-kernel=${STAGING_INCDIR} \ |
| 32 | " |
| 33 | PACKAGECONFIG ?= "${@bb.utils.filter('DISTRO_FEATURES', 'ipv6', d)}" |
| 34 | |
| 35 | PACKAGECONFIG[ipv6] = "--enable-ipv6,--disable-ipv6," |
| 36 | |
| 37 | # libnfnetlink recipe is in meta-networking layer |
| 38 | PACKAGECONFIG[libnfnetlink] = "--enable-libnfnetlink,--disable-libnfnetlink,libnfnetlink libnetfilter-conntrack" |
| 39 | |
| 40 | # libnftnl recipe is in meta-networking layer(previously known as libnftables) |
| 41 | PACKAGECONFIG[libnftnl] = "--enable-nftables,--disable-nftables,libnftnl" |
| 42 | |
| 43 | do_configure_prepend() { |
| 44 | # Remove some libtool m4 files |
| 45 | # Keep ax_check_linker_flags.m4 which belongs to autoconf-archive. |
| 46 | rm -f libtool.m4 lt~obsolete.m4 ltoptions.m4 ltsugar.m4 ltversion.m4 |
| 47 | } |