Andrew Geissler | 82c905d | 2020-04-13 13:39:40 -0500 | [diff] [blame] | 1 | SUMMARY = "The GIMP is the GNU Image Manipulation Program" |
| 2 | HOMEPAGE = "http://www.gimp.org" |
| 3 | SECTION = "x11/graphics" |
| 4 | LICENSE = "GPLv3" |
| 5 | LIC_FILES_CHKSUM = "file://COPYING;md5=c678957b0c8e964aa6c70fd77641a71e" |
| 6 | |
| 7 | DEPENDS = " \ |
Andrew Geissler | 97771a3 | 2021-03-05 15:23:11 -0600 | [diff] [blame] | 8 | alsa-lib \ |
| 9 | atk \ |
| 10 | cairo \ |
| 11 | fontconfig \ |
| 12 | freetype \ |
Andrew Geissler | 82c905d | 2020-04-13 13:39:40 -0500 | [diff] [blame] | 13 | gdk-pixbuf-native \ |
| 14 | intltool-native \ |
| 15 | libxslt-native \ |
| 16 | gegl-native \ |
| 17 | dbus-glib \ |
| 18 | gtk+ \ |
| 19 | babl \ |
| 20 | gegl \ |
| 21 | libmypaint \ |
| 22 | mypaint-brushes-1.0 \ |
| 23 | gexiv2 \ |
| 24 | jpeg \ |
Andrew Geissler | 97771a3 | 2021-03-05 15:23:11 -0600 | [diff] [blame] | 25 | libmng \ |
Andrew Geissler | 82c905d | 2020-04-13 13:39:40 -0500 | [diff] [blame] | 26 | libpng \ |
| 27 | libexif \ |
| 28 | tiff \ |
| 29 | lcms \ |
| 30 | poppler \ |
| 31 | poppler-data \ |
| 32 | jasper \ |
| 33 | bzip2 \ |
| 34 | libgudev \ |
| 35 | libmng \ |
| 36 | ${@bb.utils.contains('DISTRO_FEATURES', 'x11', 'libxmu libxpm', '', d)} \ |
| 37 | " |
| 38 | DEPENDS_append_libc-musl = " libexecinfo" |
| 39 | |
| 40 | inherit features_check gnomebase gtk-icon-cache gtk-doc mime-xdg |
| 41 | |
| 42 | REQUIRED_DISTRO_FEATURES = "x11" |
| 43 | |
| 44 | SHPV = "${@gnome_verdir("${PV}")}" |
| 45 | |
Andrew Geissler | ac970dd | 2021-02-12 15:32:45 -0600 | [diff] [blame] | 46 | SRC_URI = "https://download.gimp.org/pub/${BPN}/v${SHPV}/${BP}.tar.bz2 \ |
| 47 | file://0001-configure.ac-fix-with-linux-input-handling-with-upco.patch \ |
| 48 | " |
Andrew Geissler | bbbd5f4 | 2020-10-30 15:42:48 -0500 | [diff] [blame] | 49 | SRC_URI[sha256sum] = "2db84b57f3778d80b3466d7c21a21d22e315c7b062de2883cbaaeda9a0f618bb" |
Andrew Geissler | 82c905d | 2020-04-13 13:39:40 -0500 | [diff] [blame] | 50 | |
| 51 | EXTRA_OECONF = "--disable-python \ |
| 52 | --without-webkit \ |
Andrew Geissler | 97771a3 | 2021-03-05 15:23:11 -0600 | [diff] [blame] | 53 | --disable-check-update \ |
Andrew Geissler | 82c905d | 2020-04-13 13:39:40 -0500 | [diff] [blame] | 54 | --without-wmf" |
| 55 | |
Andrew Geissler | f103a7f | 2021-05-07 16:09:40 -0500 | [diff] [blame] | 56 | EXTRA_OECONF_append_mipsarch = " --disable-vector-icons" |
Andrew Geissler | 32b1199 | 2021-03-31 13:37:05 -0500 | [diff] [blame] | 57 | EXTRA_OECONF_append_libc-musl_riscv32 = " --disable-vector-icons" |
Andrew Geissler | f103a7f | 2021-05-07 16:09:40 -0500 | [diff] [blame] | 58 | EXTRA_OECONF_append_libc-musl_x86 = " --disable-vector-icons" |
Andrew Geissler | 97771a3 | 2021-03-05 15:23:11 -0600 | [diff] [blame] | 59 | EXTRA_OECONF_append_arm = " --disable-vector-icons" |
Andrew Geissler | 82c905d | 2020-04-13 13:39:40 -0500 | [diff] [blame] | 60 | |
| 61 | do_configure_append() { |
| 62 | find ${B} -name Makefile | xargs sed -i s:'-I$(includedir)':'-I.':g |
| 63 | find ${B} -name Makefile | xargs sed -i s:'-I/usr/include':'-I${STAGING_INCDIR}':g |
| 64 | } |
| 65 | |
| 66 | do_compile_prepend() { |
| 67 | # Let native babl/gegl find their plugins |
| 68 | export BABL_PATH=`find ${STAGING_LIBDIR_NATIVE} -maxdepth 1 -name 'babl-*'` |
| 69 | export GEGL_PATH=`find ${STAGING_LIBDIR_NATIVE} -maxdepth 1 -name 'gegl-*'` |
| 70 | } |
| 71 | |
| 72 | FILES_${PN} += "${datadir}/metainfo" |
| 73 | |
| 74 | RDEPENDS_${PN} += "mypaint-brushes-1.0" |