blob: 7314eaf7b8d2b7eb68977e3b715f0970864bf5ee [file] [log] [blame]
Brad Bishopc342db32019-05-15 21:57:59 -04001SUMMARY = "Package manager forked from Yum, using libsolv as a dependency resolver"
Brad Bishopf3f93bb2019-10-16 14:33:32 -04002DESCRIPTION = "Software package manager that installs, updates, and removes \
3packages on RPM-based Linux distributions. It automatically computes \
4dependencies and determines the actions required to install packages."
Andrew Geissler90fd73c2021-03-05 15:25:55 -06005HOMEPAGE = "https://github.com/rpm-software-management/dnf"
Brad Bishopc342db32019-05-15 21:57:59 -04006LICENSE = "GPLv2"
7LIC_FILES_CHKSUM = "file://COPYING;md5=b234ee4d69f5fce4486a80fdaf4a4263 \
8 file://PACKAGE-LICENSING;md5=4a0548e303dbc77f067335b4d688e745 \
9 "
10
11SRC_URI = "git://github.com/rpm-software-management/dnf.git \
12 file://0001-Corretly-install-tmpfiles.d-configuration.patch \
13 file://0001-Do-not-hardcode-etc-and-systemd-unit-directories.patch \
14 file://0005-Do-not-prepend-installroot-to-logdir.patch \
15 file://0029-Do-not-set-PYTHON_INSTALL_DIR-by-running-python.patch \
16 file://0030-Run-python-scripts-using-env.patch \
Andrew Geissler82c905d2020-04-13 13:39:40 -050017 file://0001-set-python-path-for-completion_helper.patch \
Andrew Geissler4b740dc2020-05-05 08:54:39 -050018 file://0001-dnf-write-the-log-lock-to-root.patch \
William A. Kennington IIIac69b482021-06-02 12:28:27 -070019 file://0001-dnf-rpm-miscutils.py-fix-usage-of-_.patch \
20 file://0002-dnf-rpm-miscutils.py-do-not-hardcode-usr-bin-rpmkeys.patch \
Brad Bishopc342db32019-05-15 21:57:59 -040021 "
22
William A. Kennington IIIac69b482021-06-02 12:28:27 -070023SRCREV = "395541fbf8f87f81cdca7567f22be1182e55bea7"
Brad Bishopc342db32019-05-15 21:57:59 -040024UPSTREAM_CHECK_GITTAGREGEX = "(?P<pver>\d+(\.\d+)+)"
25
26S = "${WORKDIR}/git"
27
28inherit cmake gettext bash-completion distutils3-base systemd
29
30DEPENDS += "libdnf librepo libcomps python3-iniparse"
31
32# manpages generation requires http://www.sphinx-doc.org/
33EXTRA_OECMAKE = " -DWITH_MAN=0 -DPYTHON_INSTALL_DIR=${PYTHON_SITEPACKAGES_DIR} -DPYTHON_DESIRED=3"
34
35BBCLASSEXTEND = "native nativesdk"
36
37RDEPENDS_${PN} += " \
38 python3-core \
39 python3-codecs \
40 python3-netclient \
41 python3-email \
42 python3-threading \
43 python3-distutils \
44 python3-logging \
45 python3-fcntl \
46 librepo \
47 python3-shell \
48 libcomps \
49 libdnf \
50 python3-sqlite3 \
51 python3-compression \
52 python3-rpm \
53 python3-iniparse \
54 python3-json \
55 python3-curses \
56 python3-misc \
57 python3-gpg \
58 "
59
60RDEPENDS_${PN}_class-native = ""
61
62RRECOMMENDS_${PN}_class-target += "gnupg"
63
64# Create a symlink called 'dnf' as 'make install' does not do it, but
65# .spec file in dnf source tree does (and then Fedora and dnf documentation
66# says that dnf binary is plain 'dnf').
67do_install_append() {
68 lnr ${D}/${bindir}/dnf-3 ${D}/${bindir}/dnf
69 lnr ${D}/${bindir}/dnf-automatic-3 ${D}/${bindir}/dnf-automatic
70}
71
72# Direct dnf-native to read rpm configuration from our sysroot, not the one it was compiled in
73do_install_append_class-native() {
74 create_wrapper ${D}/${bindir}/dnf \
75 RPM_CONFIGDIR=${STAGING_LIBDIR_NATIVE}/rpm \
76 RPM_NO_CHROOT_FOR_SCRIPTS=1
77}
78
79do_install_append_class-nativesdk() {
80 create_wrapper ${D}/${bindir}/dnf \
81 RPM_CONFIGDIR=${SDKPATHNATIVE}${libdir_nativesdk}/rpm \
Brad Bishopf3f93bb2019-10-16 14:33:32 -040082 RPM_NO_CHROOT_FOR_SCRIPTS=1
Brad Bishopc342db32019-05-15 21:57:59 -040083}
84
85SYSTEMD_SERVICE_${PN} = "dnf-makecache.service dnf-makecache.timer \
86 dnf-automatic.service dnf-automatic.timer \
87 dnf-automatic-download.service dnf-automatic-download.timer \
88 dnf-automatic-install.service dnf-automatic-install.timer \
89 dnf-automatic-notifyonly.service dnf-automatic-notifyonly.timer \
90"
91SYSTEMD_AUTO_ENABLE ?= "disable"
Andrew Geissler82c905d2020-04-13 13:39:40 -050092
93PNBLACKLIST[dnf] ?= "${@bb.utils.contains('PACKAGE_CLASSES', 'package_rpm', '', 'does not build without package_rpm in PACKAGE_CLASSES due disabled rpm support in libsolv', d)}"