Brad Bishop | 1932369 | 2019-04-05 15:28:33 -0400 | [diff] [blame] | 1 | SUMMARY = "GNOME XSLT library" |
Andrew Geissler | 90fd73c | 2021-03-05 15:25:55 -0600 | [diff] [blame] | 2 | DESCRIPTION = "libxslt is the XSLT C parser and toolkit developed for the Gnome project. \ |
| 3 | XSLT itself is a an XML language to define transformation for XML. Libxslt is based on \ |
| 4 | libxml2 the XML C library developed for the GNOME project. It also implements most of \ |
| 5 | the EXSLT set of processor-portable extensions functions and some of Saxon's evaluate \ |
| 6 | and expressions extensions." |
Brad Bishop | 1932369 | 2019-04-05 15:28:33 -0400 | [diff] [blame] | 7 | HOMEPAGE = "http://xmlsoft.org/XSLT/" |
| 8 | BUGTRACKER = "https://bugzilla.gnome.org/" |
| 9 | |
| 10 | LICENSE = "MIT" |
| 11 | LIC_FILES_CHKSUM = "file://Copyright;md5=0cd9a07afbeb24026c9b03aecfeba458" |
| 12 | |
| 13 | SECTION = "libs" |
| 14 | DEPENDS = "libxml2" |
| 15 | |
Brad Bishop | f3fd288 | 2019-06-21 08:06:37 -0400 | [diff] [blame] | 16 | SRC_URI = "http://xmlsoft.org/sources/libxslt-${PV}.tar.gz \ |
Brad Bishop | 6dbb316 | 2019-11-25 09:41:34 -0500 | [diff] [blame] | 17 | " |
Brad Bishop | 1932369 | 2019-04-05 15:28:33 -0400 | [diff] [blame] | 18 | |
Brad Bishop | 6dbb316 | 2019-11-25 09:41:34 -0500 | [diff] [blame] | 19 | SRC_URI[md5sum] = "db8765c8d076f1b6caafd9f2542a304a" |
| 20 | SRC_URI[sha256sum] = "98b1bd46d6792925ad2dfe9a87452ea2adebf69dcb9919ffd55bf926a7f93f7f" |
Brad Bishop | 1932369 | 2019-04-05 15:28:33 -0400 | [diff] [blame] | 21 | |
| 22 | UPSTREAM_CHECK_REGEX = "libxslt-(?P<pver>\d+(\.\d+)+)\.tar" |
| 23 | |
| 24 | S = "${WORKDIR}/libxslt-${PV}" |
| 25 | |
| 26 | BINCONFIG = "${bindir}/xslt-config" |
| 27 | |
Andrew Geissler | 82c905d | 2020-04-13 13:39:40 -0500 | [diff] [blame] | 28 | inherit autotools pkgconfig binconfig-disabled lib_package multilib_header |
Brad Bishop | 1932369 | 2019-04-05 15:28:33 -0400 | [diff] [blame] | 29 | |
Brad Bishop | 1932369 | 2019-04-05 15:28:33 -0400 | [diff] [blame] | 30 | do_configure_prepend () { |
Brad Bishop | 15ae250 | 2019-06-18 21:44:24 -0400 | [diff] [blame] | 31 | # We don't DEPEND on binutils for ansidecl.h so ensure we don't use the header. |
| 32 | # This can be removed when upgrading to 1.1.34. |
Brad Bishop | 1932369 | 2019-04-05 15:28:33 -0400 | [diff] [blame] | 33 | sed -i -e 's/ansidecl.h//' ${S}/configure.ac |
| 34 | |
| 35 | # The timestamps in the 1.1.28 tarball are messed up causing this file to |
| 36 | # appear out of date. Touch it so that we don't try to regenerate it. |
| 37 | touch ${S}/doc/xsltproc.1 |
| 38 | } |
| 39 | |
| 40 | EXTRA_OECONF = "--without-python --without-debug --without-mem-debug --without-crypto --with-html-subdir=${BPN}" |
| 41 | # older versions of this recipe had ${PN}-utils |
| 42 | RPROVIDES_${PN}-bin += "${PN}-utils" |
| 43 | RCONFLICTS_${PN}-bin += "${PN}-utils" |
| 44 | RREPLACES_${PN}-bin += "${PN}-utils" |
| 45 | |
| 46 | # This is only needed until libxml can load the relocated catalog itself |
| 47 | do_install_append_class-native () { |
| 48 | create_wrapper ${D}/${bindir}/xsltproc XML_CATALOG_FILES=${sysconfdir}/xml/catalog |
| 49 | } |
| 50 | |
Andrew Geissler | 82c905d | 2020-04-13 13:39:40 -0500 | [diff] [blame] | 51 | do_install_append () { |
| 52 | oe_multilib_header libxslt/xsltconfig.h |
| 53 | } |
| 54 | |
Brad Bishop | 1932369 | 2019-04-05 15:28:33 -0400 | [diff] [blame] | 55 | FILES_${PN} += "${libdir}/libxslt-plugins" |
| 56 | FILES_${PN}-dev += "${libdir}/xsltConf.sh" |
| 57 | |
| 58 | BBCLASSEXTEND = "native nativesdk" |