Andrew Geissler | a2681d9 | 2020-10-16 10:17:07 -0500 | [diff] [blame] | 1 | SUMMARY = "C library and tools for interacting with the linux GPIO character device" |
| 2 | AUTHOR = "Bartosz Golaszewski <bgolaszewski@baylibre.com>" |
Andrew Geissler | 82c905d | 2020-04-13 13:39:40 -0500 | [diff] [blame] | 3 | |
Andrew Geissler | a2681d9 | 2020-10-16 10:17:07 -0500 | [diff] [blame] | 4 | LICENSE = "LGPLv2.1+" |
| 5 | LIC_FILES_CHKSUM = "file://COPYING;md5=2caced0b25dfefd4c601d92bd15116de" |
Andrew Geissler | 82c905d | 2020-04-13 13:39:40 -0500 | [diff] [blame] | 6 | |
Andrew Geissler | ac970dd | 2021-02-12 15:32:45 -0600 | [diff] [blame^] | 7 | SRC_URI = "https://www.kernel.org/pub/software/libs/${BPN}/${BP}.tar.xz \ |
| 8 | file://run-ptest \ |
| 9 | " |
| 10 | |
Andrew Geissler | 8fc454f | 2020-12-11 16:27:59 -0600 | [diff] [blame] | 11 | SRC_URI[md5sum] = "4765470becb619fead3cdaeac61b9a77" |
| 12 | SRC_URI[sha256sum] = "c601e71846f5ab140c83bc757fdd62a4fda24a9cee39cc5e99c96ec2bf1b06a9" |
Andrew Geissler | 82c905d | 2020-04-13 13:39:40 -0500 | [diff] [blame] | 13 | |
Andrew Geissler | ac970dd | 2021-02-12 15:32:45 -0600 | [diff] [blame^] | 14 | inherit autotools pkgconfig python3native ptest |
Andrew Geissler | 82c905d | 2020-04-13 13:39:40 -0500 | [diff] [blame] | 15 | |
Andrew Geissler | 8fc454f | 2020-12-11 16:27:59 -0600 | [diff] [blame] | 16 | PACKAGECONFIG[tests] = "--enable-tests,--disable-tests,kmod udev glib-2.0 catch2" |
Andrew Geissler | a2681d9 | 2020-10-16 10:17:07 -0500 | [diff] [blame] | 17 | PACKAGECONFIG[cxx] = "--enable-bindings-cxx,--disable-bindings-cxx" |
Andrew Geissler | 82c905d | 2020-04-13 13:39:40 -0500 | [diff] [blame] | 18 | PACKAGECONFIG[python3] = "--enable-bindings-python,--disable-bindings-python,python3" |
| 19 | |
Andrew Geissler | a2681d9 | 2020-10-16 10:17:07 -0500 | [diff] [blame] | 20 | # Enable cxx bindings by default. |
| 21 | PACKAGECONFIG ?= "cxx" |
| 22 | |
| 23 | # Always build tools - they don't have any additional |
| 24 | # requirements over the library. |
| 25 | EXTRA_OECONF = "--enable-tools" |
| 26 | |
| 27 | DEPENDS += "autoconf-archive-native" |
| 28 | |
| 29 | PACKAGES =+ "${PN}-tools libgpiodcxx" |
| 30 | FILES_${PN}-tools = "${bindir}/*" |
| 31 | FILES_libgpiodcxx = "${libdir}/libgpiodcxx.so.*" |
Andrew Geissler | 82c905d | 2020-04-13 13:39:40 -0500 | [diff] [blame] | 32 | |
| 33 | PACKAGES =+ "${PN}-python" |
| 34 | FILES_${PN}-python = "${PYTHON_SITEPACKAGES_DIR}" |
| 35 | RRECOMMENDS_PYTHON = "${@bb.utils.contains('PACKAGECONFIG', 'python3', '${PN}-python', '',d)}" |
| 36 | RRECOMMENDS_${PN}-python += "${RRECOMMENDS_PYTHON}" |
Andrew Geissler | ac970dd | 2021-02-12 15:32:45 -0600 | [diff] [blame^] | 37 | |
| 38 | PACKAGECONFIG_append = " ${@bb.utils.contains('DISTRO_FEATURES', 'ptest', 'tests', '', d)}" |
| 39 | |
| 40 | do_install_ptest() { |
| 41 | install -d ${D}${PTEST_PATH}/tests |
| 42 | cp ${B}/tests/.libs/gpiod-test ${D}${PTEST_PATH}/tests/ |
| 43 | } |