blob: 616e8804538beb9089fea32248138015425f4fed [file] [log] [blame]
Andrew Geissler82c905d2020-04-13 13:39:40 -05001SUMMARY = "Extensible memoizing collections and decorators"
2HOMEPAGE = "https://github.com/tkem/cachetools"
3DESCRIPTION = "This module provides various memoizing \
4collections and decorators, including variants of the \
5Python 3 Standard Library @lru_cache function decorator."
6SECTION = "devel/python"
7
8LICENSE = "MIT"
9LIC_FILES_CHKSUM = "file://LICENSE;md5=2d1e1bf0ccb26126a230c51f997ce362"
10
Andrew Geisslerc87764f2020-06-27 00:16:32 -050011inherit pypi setuptools3 ptest
12
13SRC_URI += " \
14 file://run-ptest \
15"
16
Andrew Geissler72956ed2021-01-08 16:11:14 -060017RDEPENDS_${PN} += " \
18 ${PYTHON_PN}-math \
19"
20
Andrew Geisslerc87764f2020-06-27 00:16:32 -050021RDEPENDS_${PN}-ptest += " \
22 ${PYTHON_PN}-pytest \
23"
24
25do_install_ptest() {
26 install -d ${D}${PTEST_PATH}/tests
27 cp -rf ${S}/tests/* ${D}${PTEST_PATH}/tests/
28}
Andrew Geissler82c905d2020-04-13 13:39:40 -050029
Andrew Geisslereef63862021-01-29 15:58:13 -060030SRC_URI[sha256sum] = "f469e29e7aa4cff64d8de4aad95ce76de8ea1125a16c68e0d93f65c3c3dc92e9"
Andrew Geissler82c905d2020-04-13 13:39:40 -050031
32BBCLASSEXTEND = "native nativesdk"