Vijay Khemka | c32281b | 2019-08-20 11:59:14 -0700 | [diff] [blame] | 1 | FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:" |
| 2 | |
| 3 | # Pin to rsyslog v8.1904.0 for now |
| 4 | # v8.1903.0 has a couple issues with the imjournal module: |
| 5 | # 1. Enabling the "WorkAroundJournalBug" option causes rsyslogd to fail to start |
| 6 | # 2. Logging data especially while rotating the journal causes a double free error |
| 7 | PV = "8.1904.0" |
| 8 | SRC_URI[md5sum] = "b9398b5aa68a829bf2c18a87490d30c0" |
| 9 | SRC_URI[sha256sum] = "7098b459dfc3f8bfc35d5b114c56e7945614ba76efa4e513b1db9c38b0ff9c3d" |
| 10 | |
| 11 | SRC_URI += "file://rsyslog.conf \ |
| 12 | file://rsyslog.logrotate \ |
| 13 | file://rotate-event-logs.service \ |
| 14 | file://rotate-event-logs.timer \ |
| 15 | " |
| 16 | |
| 17 | PACKAGECONFIG_append = " imjournal" |
| 18 | |
| 19 | do_install_append() { |
| 20 | install -m 0644 ${WORKDIR}/rotate-event-logs.service ${D}${systemd_system_unitdir} |
| 21 | install -m 0644 ${WORKDIR}/rotate-event-logs.timer ${D}${systemd_system_unitdir} |
| 22 | rm ${D}${sysconfdir}/rsyslog.d/imjournal.conf |
| 23 | } |
| 24 | |
| 25 | SYSTEMD_SERVICE_${PN} += " rotate-event-logs.service rotate-event-logs.timer" |