Brad Bishop | c342db3 | 2019-05-15 21:57:59 -0400 | [diff] [blame] | 1 | SUMMARY = "A Perl module that checks whether a particular C library and its headers are available" |
| 2 | DESCRIPTION = "This module provides a way of checking whether a particular library \ |
| 3 | and its headers are available, by attempting to compile a simple program and \ |
| 4 | link against it." |
| 5 | HOMEPAGE = "https://metacpan.org/pod/Devel::CheckLib" |
| 6 | SECTION = "libs" |
Andrew Geissler | 9aee500 | 2022-03-30 16:27:02 +0000 | [diff] [blame] | 7 | LICENSE = "Artistic-1.0 | GPL-1.0-or-later" |
Brad Bishop | c342db3 | 2019-05-15 21:57:59 -0400 | [diff] [blame] | 8 | |
| 9 | LIC_FILES_CHKSUM = "file://README;md5=7911cdbb572d25c5f2e2ea17f669efc2" |
| 10 | |
| 11 | SRC_URI = "https://cpan.metacpan.org/modules/by-module/Devel/Devel-CheckLib-${PV}.tar.gz \ |
| 12 | file://0001-CheckLib.pm-don-t-execute-the-binary.patch \ |
| 13 | " |
Andrew Geissler | 87f5cff | 2022-09-30 13:13:31 -0500 | [diff] [blame] | 14 | SRC_URI[sha256sum] = "869d38c258e646dcef676609f0dd7ca90f085f56cf6fd7001b019a5d5b831fca" |
Brad Bishop | c342db3 | 2019-05-15 21:57:59 -0400 | [diff] [blame] | 15 | |
| 16 | S = "${WORKDIR}/Devel-CheckLib-${PV}" |
| 17 | |
| 18 | inherit cpan |
| 19 | |
Andrew Geissler | 615f2f1 | 2022-07-15 14:00:58 -0500 | [diff] [blame] | 20 | do_install:append() { |
| 21 | # update interpreter on shebang line |
| 22 | # since old version env doesn't support multiple arguments, replace option |
| 23 | # '-w' with 'use warnings;' |
| 24 | sed -i -e "s:^#!.*:#!/usr/bin/env perl:" \ |
| 25 | -e "/use strict;/ause warnings;" ${D}${bindir}/use-devel-checklib |
| 26 | } |
| 27 | |
Brad Bishop | c342db3 | 2019-05-15 21:57:59 -0400 | [diff] [blame] | 28 | BBCLASSEXTEND="native" |