Andrew Geissler | 517393d | 2023-01-13 08:55:19 -0600 | [diff] [blame] | 1 | SUMMARY = "Smart card library and applications" |
| 2 | DESCRIPTION = "OpenSC is a tool for accessing smart card devices. Basic\ |
| 3 | functionality (e.g. SELECT FILE, READ BINARY) should work on any ISO\ |
| 4 | 7816-4 compatible smart card. Encryption and decryption using private\ |
| 5 | keys on the smart card is possible with PKCS\ |
| 6 | such as the FINEID (Finnish Electronic IDentity) card. Swedish Posten\ |
| 7 | eID cards have also been confirmed to work." |
| 8 | |
Andrew Geissler | c5535c9 | 2023-01-27 16:10:19 -0600 | [diff] [blame] | 9 | HOMEPAGE = "https://github.com/OpenSC/OpenSC/wiki" |
Andrew Geissler | 517393d | 2023-01-13 08:55:19 -0600 | [diff] [blame] | 10 | SECTION = "System Environment/Libraries" |
| 11 | LICENSE = "LGPL-2.0-or-later" |
| 12 | LIC_FILES_CHKSUM = "file://COPYING;md5=cb8aedd3bced19bd8026d96a8b6876d7" |
| 13 | |
| 14 | #v0.21.0 |
| 15 | SRCREV = "5497519ea6b4af596628f8f8f2f904bacaa3148f" |
| 16 | SRC_URI = "git://github.com/OpenSC/OpenSC;branch=master;protocol=https \ |
Patrick Williams | 864cc43 | 2023-02-09 14:54:44 -0600 | [diff] [blame] | 17 | file://0001-pkcs11-tool-Fix-private-key-import.patch \ |
| 18 | file://0002-pkcs11-tool-Log-more-information-on-OpenSSL-errors.patch \ |
Andrew Geissler | 220dafd | 2023-10-04 10:18:08 -0500 | [diff] [blame] | 19 | file://CVE-2023-2977.patch \ |
Andrew Geissler | 517393d | 2023-01-13 08:55:19 -0600 | [diff] [blame] | 20 | " |
| 21 | DEPENDS = "virtual/libiconv openssl" |
| 22 | |
| 23 | S = "${WORKDIR}/git" |
| 24 | inherit autotools pkgconfig bash-completion |
| 25 | |
| 26 | EXTRA_OECONF = " \ |
| 27 | --disable-static \ |
| 28 | --disable-ctapi \ |
| 29 | --disable-doc \ |
| 30 | --disable-strict \ |
| 31 | " |
| 32 | EXTRA_OEMAKE = "DESTDIR=${D}" |
| 33 | |
| 34 | PACKAGECONFIG ??= "pcsc" |
| 35 | |
| 36 | PACKAGECONFIG[openct] = "--enable-openct,--disable-openct,openct" |
| 37 | PACKAGECONFIG[pcsc] = "--enable-pcsc,--disable-pcsc,pcsc-lite,pcsc-lite pcsc-lite-lib" |
| 38 | |
| 39 | RDEPENDS:${PN} = "readline" |
| 40 | |
| 41 | FILES:${PN} += "\ |
| 42 | ${libdir}/opensc-pkcs11.so \ |
| 43 | ${libdir}/onepin-opensc-pkcs11.so \ |
| 44 | ${libdir}/pkcs11-spy.so \ |
| 45 | " |
| 46 | FILES:${PN}-dev += "\ |
| 47 | ${libdir}/pkcs11/opensc-pkcs11.so \ |
| 48 | ${libdir}/pkcs11/onepin-opensc-pkcs11.so \ |
| 49 | ${libdir}/pkcs11/pkcs11-spy.so \ |
| 50 | " |
| 51 | |
| 52 | BBCLASSEXTEND = "native" |