Patrick Williams | ac13d5f | 2023-11-24 18:59:46 -0600 | [diff] [blame] | 1 | SUMMARY = "XML Security Library is a C library based on LibXML2" |
| 2 | DESCRIPTION = "\ |
| 3 | XML Security Library is a C library based on \ |
| 4 | LibXML2 and OpenSSL. The library was created with a goal to support major \ |
| 5 | XML security standards "XML Digital Signature" and "XML Encryption". \ |
| 6 | " |
| 7 | HOMEPAGE = "http://www.aleksey.com/xmlsec/" |
| 8 | DEPENDS = "libtool libxml2 libxslt zlib" |
| 9 | |
| 10 | LICENSE = "MIT" |
| 11 | LIC_FILES_CHKSUM = "file://COPYING;md5=352791d62092ea8104f085042de7f4d0" |
| 12 | |
| 13 | SECTION = "libs" |
| 14 | |
| 15 | SRC_URI = "http://www.aleksey.com/xmlsec/download/${BP}.tar.gz \ |
| 16 | file://fix-ltmain.sh.patch \ |
| 17 | file://change-finding-path-of-nss.patch \ |
| 18 | file://makefile-ptest.patch \ |
| 19 | file://xmlsec1-examples-allow-build-in-separate-dir.patch \ |
| 20 | file://0001-nss-nspr-fix-for-multilib.patch \ |
| 21 | file://run-ptest \ |
| 22 | file://ensure-search-path-non-host.patch \ |
| 23 | " |
| 24 | |
| 25 | SRC_URI[sha256sum] = "4003c56b3d356d21b1db7775318540fad6bfedaf5f117e8f7c010811219be3cf" |
| 26 | |
| 27 | inherit autotools-brokensep ptest pkgconfig |
| 28 | |
| 29 | #CFLAGS += "-I${STAGING_INCDIR}/nss3" |
| 30 | #CPPFLAGS += "-I${STAGING_INCDIR}/nss3" |
| 31 | |
| 32 | PACKAGECONFIG ??= "gnutls libgcrypt nss openssl des" |
| 33 | PACKAGECONFIG[gnutls] = ",,gnutls" |
| 34 | PACKAGECONFIG[libgcrypt] = ",,libgcrypt" |
| 35 | PACKAGECONFIG[nss] = "--with-nss=${STAGING_DIR_HOST} --with-nspr=${STAGING_DIR_HOST},--with-nss=no --with-nspr=no,nss nspr" |
| 36 | PACKAGECONFIG[openssl] = ",,openssl" |
| 37 | PACKAGECONFIG[des] = ",--disable-des,," |
| 38 | |
| 39 | # these can be dynamically loaded with xmlSecCryptoDLLoadLibrary() |
| 40 | FILES_SOLIBSDEV = "${libdir}/libxmlsec1.so" |
| 41 | FILES:${PN} += "${libdir}/libxmlsec1-*.so" |
| 42 | INSANE_SKIP:${PN} = "dev-so" |
| 43 | |
| 44 | FILES:${PN}-dev += "${libdir}/xmlsec1Conf.sh" |
| 45 | FILES:${PN}-dbg += "${PTEST_PATH}/.debug/*" |
| 46 | |
| 47 | RDEPENDS:${PN}-ptest += "${PN}-dev" |
| 48 | INSANE_SKIP:${PN}-ptest += "dev-deps" |
| 49 | |
| 50 | PTEST_EXTRA_ARGS = "top_srcdir=${S} top_builddir=${B}" |
| 51 | |
| 52 | do_compile_ptest () { |
| 53 | oe_runmake -C ${S}/examples ${PTEST_EXTRA_ARGS} all |
| 54 | } |
| 55 | |
| 56 | do_install:append() { |
| 57 | for i in ${bindir}/xmlsec1-config ${libdir}/xmlsec1Conf.sh \ |
| 58 | ${libdir}/pkgconfig/xmlsec1-openssl.pc; do |
| 59 | sed -i -e "s@${RECIPE_SYSROOT}@@g" ${D}$i |
| 60 | done |
| 61 | } |
| 62 | |
| 63 | do_install_ptest () { |
| 64 | oe_runmake -C ${S}/examples DESTDIR=${D}${PTEST_PATH} ${PTEST_EXTRA_ARGS} install-ptest |
| 65 | } |
| 66 | |
| 67 | BBCLASSEXTEND = "native" |