Andrew Geissler | 595f630 | 2022-01-24 19:11:47 +0000 | [diff] [blame] | 1 | SUMMARY = "Lightweight and flexible command-line JSON processor" |
| 2 | DESCRIPTION = "jq is like sed for JSON data, you can use it to slice and \ |
| 3 | filter and map and transform structured data with the same \ |
| 4 | ease that sed, awk, grep and friends let you play with text." |
| 5 | HOMEPAGE = "https://stedolan.github.io/jq/" |
| 6 | BUGTRACKER = "https://github.com/stedolan/jq/issues" |
| 7 | SECTION = "utils" |
| 8 | LICENSE = "MIT" |
| 9 | LIC_FILES_CHKSUM = "file://COPYING;md5=2814b59e00e7918c864fa3b6bbe049b4" |
| 10 | |
| 11 | PV = "1.6+git${SRCPV}" |
Andrew Geissler | 87f5cff | 2022-09-30 13:13:31 -0500 | [diff] [blame] | 12 | SRC_URI = "git://github.com/stedolan/jq;protocol=https;branch=master \ |
| 13 | file://0001-configure-Pass-_XOPEN_SOURCE-when-checking-for-strpt.patch \ |
| 14 | file://0002-builtin-Replace-_BSD_SOURCE-with-_DEFAULT_SOURCE.patch \ |
| 15 | file://run-ptest \ |
| 16 | " |
| 17 | SRCREV = "cff5336ec71b6fee396a95bb0e4bea365e0cd1e8" |
Andrew Geissler | 595f630 | 2022-01-24 19:11:47 +0000 | [diff] [blame] | 18 | S = "${WORKDIR}/git" |
| 19 | |
Andrew Geissler | 87f5cff | 2022-09-30 13:13:31 -0500 | [diff] [blame] | 20 | inherit autotools-brokensep ptest |
Andrew Geissler | 595f630 | 2022-01-24 19:11:47 +0000 | [diff] [blame] | 21 | |
| 22 | PACKAGECONFIG ?= "oniguruma" |
| 23 | |
| 24 | PACKAGECONFIG[docs] = "--enable-docs,--disable-docs,ruby-native" |
| 25 | PACKAGECONFIG[maintainer-mode] = "--enable-maintainer-mode,--disable-maintainer-mode,flex-native bison-native" |
| 26 | PACKAGECONFIG[oniguruma] = "--with-oniguruma,--without-oniguruma,onig" |
Patrick Williams | 2390b1b | 2022-11-03 13:47:49 -0500 | [diff] [blame] | 27 | # enable if you want ptest running under valgrind |
| 28 | PACKAGECONFIG[valgrind] = "--enable-valgrind,--disable-valgrind,valgrind" |
Andrew Geissler | 595f630 | 2022-01-24 19:11:47 +0000 | [diff] [blame] | 29 | |
Andrew Geissler | 87f5cff | 2022-09-30 13:13:31 -0500 | [diff] [blame] | 30 | do_install_ptest() { |
| 31 | cp -rf ${B}/tests ${D}${PTEST_PATH} |
| 32 | cp -rf ${B}/.libs ${D}${PTEST_PATH} |
| 33 | # libjq.so.* is packaged in the main jq component, so remove it from ptest |
| 34 | rm -f ${D}${PTEST_PATH}/.libs/libjq.so.* |
| 35 | ln -sf ${bindir}/jq ${D}${PTEST_PATH} |
Patrick Williams | 2390b1b | 2022-11-03 13:47:49 -0500 | [diff] [blame] | 36 | if [ "${@bb.utils.contains('PACKAGECONFIG', 'valgrind', 'true', 'false', d)}" = "false" ]; then |
| 37 | sed -i 's:#export NO_VALGRIND=1:export NO_VALGRIND=1:g' ${D}${PTEST_PATH}/run-ptest |
| 38 | fi |
| 39 | # handle multilib |
| 40 | sed -i s:@libdir@:${libdir}:g ${D}${PTEST_PATH}/run-ptest |
Andrew Geissler | 87f5cff | 2022-09-30 13:13:31 -0500 | [diff] [blame] | 41 | } |
| 42 | |
Andrew Geissler | 595f630 | 2022-01-24 19:11:47 +0000 | [diff] [blame] | 43 | BBCLASSEXTEND = "native" |