Brad Bishop | 996bc45 | 2019-12-02 13:05:15 -0500 | [diff] [blame] | 1 | SUMMARY = "The Mercurial distributed SCM" |
| 2 | HOMEPAGE = "http://mercurial.selenic.com/" |
| 3 | SECTION = "console/utils" |
Andrew Geissler | 9aee500 | 2022-03-30 16:27:02 +0000 | [diff] [blame] | 4 | LICENSE = "GPL-2.0-only" |
Brad Bishop | 996bc45 | 2019-12-02 13:05:15 -0500 | [diff] [blame] | 5 | LIC_FILES_CHKSUM = "file://COPYING;md5=b234ee4d69f5fce4486a80fdaf4a4263" |
| 6 | |
| 7 | DEPENDS = "python3 python3-native" |
Patrick Williams | 213cb26 | 2021-08-07 19:21:33 -0500 | [diff] [blame] | 8 | RDEPENDS:${PN} = "python3 python3-modules" |
Brad Bishop | 996bc45 | 2019-12-02 13:05:15 -0500 | [diff] [blame] | 9 | |
Patrick Williams | 864cc43 | 2023-02-09 14:54:44 -0600 | [diff] [blame] | 10 | inherit python3native python3targetconfig |
Brad Bishop | 996bc45 | 2019-12-02 13:05:15 -0500 | [diff] [blame] | 11 | |
| 12 | SRC_URI = "https://www.mercurial-scm.org/release/${BP}.tar.gz" |
Patrick Williams | 03907ee | 2022-05-01 06:28:52 -0500 | [diff] [blame] | 13 | SRC_URI[sha256sum] = "86f98645e4565a9256991dcde22b77b8e7d22ca6fbb60c1f4cdbd8469a38cc1f" |
Brad Bishop | 996bc45 | 2019-12-02 13:05:15 -0500 | [diff] [blame] | 14 | |
| 15 | S = "${WORKDIR}/mercurial-${PV}" |
| 16 | |
| 17 | BBCLASSEXTEND = "native" |
| 18 | |
| 19 | export LDSHARED="${CCLD} -shared" |
| 20 | |
| 21 | EXTRA_OEMAKE = "STAGING_LIBDIR=${STAGING_LIBDIR} STAGING_INCDIR=${STAGING_INCDIR} \ |
| 22 | PREFIX=${prefix}" |
| 23 | |
Patrick Williams | 213cb26 | 2021-08-07 19:21:33 -0500 | [diff] [blame] | 24 | do_configure:append () { |
Brad Bishop | 996bc45 | 2019-12-02 13:05:15 -0500 | [diff] [blame] | 25 | sed -i -e 's:PYTHON?=python:PYTHON=python3:g' ${S}/Makefile |
| 26 | } |
| 27 | |
| 28 | do_install () { |
| 29 | oe_runmake -e install-bin DESTDIR=${D} PREFIX=${prefix} |
| 30 | sed -i -e 's:${STAGING_BINDIR_NATIVE}/python3-native/python3:${USRBINPATH}/env python3:g' ${D}${bindir}/hg |
| 31 | } |
Brad Bishop | e42b3e3 | 2020-01-15 22:08:42 -0500 | [diff] [blame] | 32 | PACKAGES =+ "${PN}-python" |
Brad Bishop | 996bc45 | 2019-12-02 13:05:15 -0500 | [diff] [blame] | 33 | |
Patrick Williams | 213cb26 | 2021-08-07 19:21:33 -0500 | [diff] [blame] | 34 | FILES:${PN} += "${PYTHON_SITEPACKAGES_DIR}" |
Brad Bishop | 996bc45 | 2019-12-02 13:05:15 -0500 | [diff] [blame] | 35 | |
Patrick Williams | 213cb26 | 2021-08-07 19:21:33 -0500 | [diff] [blame] | 36 | FILES:${PN}-python = "${nonarch_libdir}/${PYTHON_DIR}" |
Brad Bishop | e42b3e3 | 2020-01-15 22:08:42 -0500 | [diff] [blame] | 37 | |