Patrick Williams | 8e7b46e | 2023-05-01 14:19:06 -0500 | [diff] [blame] | 1 | require libgpiod.inc |
| 2 | |
| 3 | LICENSE = "GPL-2.0-or-later & LGPL-2.1-or-later & CC-BY-SA-4.0" |
| 4 | LIC_FILES_CHKSUM = " \ |
| 5 | file://LICENSES/GPL-2.0-or-later.txt;md5=b234ee4d69f5fce4486a80fdaf4a4263 \ |
| 6 | file://LICENSES/LGPL-2.1-or-later.txt;md5=4b54a1fd55a448865a0b32d41598759d \ |
| 7 | file://LICENSES/CC-BY-SA-4.0.txt;md5=fba3b94d88bfb9b81369b869a1e9a20f \ |
| 8 | " |
| 9 | |
| 10 | FILESEXTRAPATHS:prepend := "${THISDIR}/${PN}-2.x:" |
| 11 | |
Andrew Geissler | 5082cc7 | 2023-09-11 08:41:39 -0400 | [diff] [blame] | 12 | SRC_URI[sha256sum] = "c3c923dc63b7b1b02639c9179c81e3d9febf0887bbaa59775990229cdbedb88b" |
Patrick Williams | 8e7b46e | 2023-05-01 14:19:06 -0500 | [diff] [blame] | 13 | |
| 14 | # Enable all project features for ptest |
| 15 | PACKAGECONFIG[tests] = "--enable-tests --enable-tools --enable-bindings-cxx --enable-gpioset-interactive,--disable-tests,kmod util-linux glib-2.0 catch2 libedit" |
| 16 | PACKAGECONFIG[gpioset-interactive] = "--enable-gpioset-interactive,--disable-gpioset-interactive,libedit" |
| 17 | |
| 18 | PACKAGES =+ "${PN}-ptest-dev" |
| 19 | FILES:${PN}-tools += "${bindir}/gpionotify" |
| 20 | FILES:${PN}-ptest += "${libdir}/libgpiosim.so.*" |
| 21 | FILES:${PN}-ptest-dev += "${includedir}/gpiosim.h" |
| 22 | |
| 23 | RRECOMMENDS:${PN}-ptest += "kernel-module-gpio-sim" |
| 24 | |
| 25 | do_install_ptest:append() { |
| 26 | install -m 0644 ${S}/tests/gpiosim/gpiosim.h ${D}${includedir}/gpiosim.h |
| 27 | } |