Andrew Geissler | d159c7f | 2021-09-02 21:05:58 -0500 | [diff] [blame] | 1 | # |
2 | # crate-fetch class | ||||
3 | # | ||||
4 | # Registers 'crate' method for Bitbake fetch2. | ||||
5 | # | ||||
6 | # Adds support for following format in recipe SRC_URI: | ||||
7 | # crate://<packagename>/<version> | ||||
8 | # | ||||
9 | |||||
10 | python () { | ||||
11 | import crate | ||||
12 | bb.fetch2.methods.append( crate.Crate() ) | ||||
13 | } |