Brad Bishop | 316dfdd | 2018-06-25 12:45:53 -0400 | [diff] [blame] | 1 | SUMMARY = "C bindings for apps which will manipulate JSON data" |
| 2 | DESCRIPTION = "JSON-C implements a reference counting object model that allows you to easily construct JSON objects in C." |
| 3 | HOMEPAGE = "https://github.com/json-c/json-c/wiki" |
| 4 | LICENSE = "MIT" |
| 5 | LIC_FILES_CHKSUM = "file://COPYING;md5=de54b60fbbc35123ba193fea8ee216f2" |
| 6 | |
| 7 | SRC_URI = "https://s3.amazonaws.com/json-c_releases/releases/${BP}.tar.gz \ |
| 8 | " |
| 9 | SRC_URI[md5sum] = "11fc5d90c77375e5fc8401e8b9efbf21" |
| 10 | SRC_URI[sha256sum] = "0316780be9ad16c42d7c26b015a784fd5df4b0909fef0aba51cfb13e492ac24d" |
| 11 | |
| 12 | UPSTREAM_CHECK_REGEX = "json-c-(?P<pver>\d+(\.\d+)+).tar" |
| 13 | # json-c releases page is fetching the list of releases in some weird XML format |
| 14 | # from https://s3.amazonaws.com/json-c_releases and processes it with javascript :-/ |
| 15 | #UPSTREAM_CHECK_URI = "https://s3.amazonaws.com/json-c_releases/releases/index.html" |
| 16 | RECIPE_UPSTREAM_VERSION = "0.13" |
| 17 | RECIPE_UPSTREAM_DATE = "Dec 07, 2017" |
| 18 | CHECK_DATE = "Jan 31, 2018" |
| 19 | |
| 20 | RPROVIDES_${PN} = "libjson" |
| 21 | |
| 22 | inherit autotools |
| 23 | |
| 24 | EXTRA_OECONF = "--enable-rdrand" |
| 25 | |
| 26 | do_configure_prepend() { |
| 27 | # Clean up autoconf cruft that should not be in the tarball |
| 28 | rm -f ${S}/config.status |
| 29 | } |
| 30 | |
| 31 | BBCLASSEXTEND = "native nativesdk" |