Andrew Geissler | 82c905d | 2020-04-13 13:39:40 -0500 | [diff] [blame] | 1 | SUMMARY = "The PyPA recommended tool for installing Python packages" |
Andrew Geissler | d25ed32 | 2020-06-27 00:28:28 -0500 | [diff] [blame] | 2 | HOMEPAGE = "https://pypi.org/project/pip" |
Andrew Geissler | 82c905d | 2020-04-13 13:39:40 -0500 | [diff] [blame] | 3 | SECTION = "devel/python" |
| 4 | LICENSE = "MIT" |
| 5 | LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=8ba06d529c955048e5ddd7c45459eb2e" |
| 6 | |
| 7 | DEPENDS += "python3 python3-setuptools-native" |
| 8 | |
| 9 | SRC_URI += "file://0001-change-shebang-to-python3.patch" |
| 10 | |
| 11 | SRC_URI[md5sum] = "7d42ba49b809604f0df3d55df1c3fd86" |
| 12 | SRC_URI[sha256sum] = "7db0c8ea4c7ea51c8049640e8e6e7fde949de672bfa4949920675563a5a6967f" |
| 13 | |
| 14 | inherit pypi distutils3 |
| 15 | |
| 16 | do_install_append() { |
| 17 | # Install as pip3 and leave pip2 as default |
| 18 | rm ${D}/${bindir}/pip |
| 19 | } |
| 20 | |
| 21 | RDEPENDS_${PN} = "\ |
| 22 | python3-compile \ |
| 23 | python3-io \ |
| 24 | python3-html \ |
| 25 | python3-json \ |
| 26 | python3-netserver \ |
| 27 | python3-setuptools \ |
| 28 | python3-unixadmin \ |
| 29 | python3-xmlrpc \ |
| 30 | python3-pickle \ |
| 31 | " |
| 32 | |
| 33 | BBCLASSEXTEND = "native nativesdk" |