Brad Bishop | 1932369 | 2019-04-05 15:28:33 -0400 | [diff] [blame] | 1 | DESCRIPTION = "gvfs is a userspace virtual filesystem" |
| 2 | LICENSE = "LGPLv2" |
| 3 | LIC_FILES_CHKSUM = "file://COPYING;md5=05df38dd77c35ec8431f212410a3329e" |
| 4 | |
| 5 | GNOMEBASEBUILDCLASS = "meson" |
Brad Bishop | e42b3e3 | 2020-01-15 22:08:42 -0500 | [diff] [blame] | 6 | inherit gnomebase gsettings bash-completion gettext upstream-version-is-even features_check useradd |
Brad Bishop | 1932369 | 2019-04-05 15:28:33 -0400 | [diff] [blame] | 7 | |
Brad Bishop | e42b3e3 | 2020-01-15 22:08:42 -0500 | [diff] [blame] | 8 | DEPENDS += "libsecret glib-2.0 glib-2.0-native libgudev shadow-native \ |
| 9 | gsettings-desktop-schemas dbus" |
Brad Bishop | 1932369 | 2019-04-05 15:28:33 -0400 | [diff] [blame] | 10 | |
Patrick Williams | 213cb26 | 2021-08-07 19:21:33 -0500 | [diff] [blame] | 11 | RDEPENDS:${PN} += "gsettings-desktop-schemas" |
Andrew Geissler | f103a7f | 2021-05-07 16:09:40 -0500 | [diff] [blame] | 12 | |
Brad Bishop | 1932369 | 2019-04-05 15:28:33 -0400 | [diff] [blame] | 13 | SRC_URI = "https://download.gnome.org/sources/${BPN}/${@gnome_verdir("${PV}")}/${BPN}-${PV}.tar.xz;name=archive" |
Andrew Geissler | 6972109 | 2021-07-23 12:57:00 -0400 | [diff] [blame] | 14 | SRC_URI[archive.sha256sum] = "b2ea4f271aad2711f16b43c03151e2ec5a9874ff1a21142ef6d6406486a19dc2" |
Brad Bishop | 1932369 | 2019-04-05 15:28:33 -0400 | [diff] [blame] | 15 | |
Brad Bishop | e42b3e3 | 2020-01-15 22:08:42 -0500 | [diff] [blame] | 16 | # depends on gsettings-desktop-schemas->gcr->gtk+3-> x11 |
| 17 | REQUIRED_DISTRO_FEATURES = "x11" |
Brad Bishop | 1932369 | 2019-04-05 15:28:33 -0400 | [diff] [blame] | 18 | |
| 19 | EXTRA_OEMESON = " \ |
| 20 | -Dbluray=false \ |
Brad Bishop | 1932369 | 2019-04-05 15:28:33 -0400 | [diff] [blame] | 21 | -Dgoa=false \ |
| 22 | -Dgoogle=false \ |
| 23 | -Dnfs=false \ |
Brad Bishop | 1932369 | 2019-04-05 15:28:33 -0400 | [diff] [blame] | 24 | " |
| 25 | |
| 26 | PACKAGES =+ "gvfsd-ftp gvfsd-sftp gvfsd-trash" |
| 27 | |
Patrick Williams | 213cb26 | 2021-08-07 19:21:33 -0500 | [diff] [blame] | 28 | FILES:${PN} += " \ |
Brad Bishop | 1932369 | 2019-04-05 15:28:33 -0400 | [diff] [blame] | 29 | ${datadir}/glib-2.0 \ |
| 30 | ${datadir}/GConf \ |
| 31 | ${datadir}/dbus-1/services \ |
| 32 | ${libdir}/gio/modules/*.so \ |
| 33 | ${libdir}/tmpfiles.d \ |
| 34 | ${systemd_user_unitdir} \ |
| 35 | " |
Brad Bishop | 1932369 | 2019-04-05 15:28:33 -0400 | [diff] [blame] | 36 | |
Patrick Williams | 213cb26 | 2021-08-07 19:21:33 -0500 | [diff] [blame] | 37 | FILES:${PN}-dbg += "${libdir}/gio/modules/.debug/*" |
| 38 | FILES:${PN}-dev += "${libdir}/gio/modules/*.la" |
Brad Bishop | 1932369 | 2019-04-05 15:28:33 -0400 | [diff] [blame] | 39 | |
Patrick Williams | 213cb26 | 2021-08-07 19:21:33 -0500 | [diff] [blame] | 40 | FILES:gvfsd-ftp = "${libexecdir}/gvfsd-ftp ${datadir}/gvfs/mounts/ftp.mount" |
| 41 | FILES:gvfsd-sftp = "${libexecdir}/gvfsd-sftp ${datadir}/gvfs/mounts/sftp.mount" |
| 42 | FILES:gvfsd-trash = "${libexecdir}/gvfsd-trash ${datadir}/gvfs/mounts/trash.mount" |
Brad Bishop | 1932369 | 2019-04-05 15:28:33 -0400 | [diff] [blame] | 43 | |
Patrick Williams | 213cb26 | 2021-08-07 19:21:33 -0500 | [diff] [blame] | 44 | RRECOMMENDS:gvfsd-ftp += "openssh-sftp openssh-ssh" |
Brad Bishop | 1932369 | 2019-04-05 15:28:33 -0400 | [diff] [blame] | 45 | |
Brad Bishop | 26bdd44 | 2019-08-16 17:08:17 -0400 | [diff] [blame] | 46 | PACKAGECONFIG ?= "libgphoto2 \ |
| 47 | ${@bb.utils.filter('DISTRO_FEATURES', 'systemd', d)} \ |
| 48 | ${@bb.utils.contains('DISTRO_FEATURES','polkit','udisks2','',d)} \ |
| 49 | ${@bb.utils.contains('DISTRO_FEATURES','polkit','admin','',d)} \ |
| 50 | " |
Brad Bishop | 1932369 | 2019-04-05 15:28:33 -0400 | [diff] [blame] | 51 | |
Brad Bishop | 26bdd44 | 2019-08-16 17:08:17 -0400 | [diff] [blame] | 52 | PACKAGECONFIG[udisks2] = "-Dudisks2=true, -Dudisks2=false, udisks2, udisks2" |
| 53 | PACKAGECONFIG[admin] = "-Dadmin=true, -Dadmin=false, libcap polkit" |
Brad Bishop | 1932369 | 2019-04-05 15:28:33 -0400 | [diff] [blame] | 54 | PACKAGECONFIG[afc] = "-Dafc=true, -Dafc=false, libimobiledevice libplist" |
| 55 | PACKAGECONFIG[archive] = "-Darchive=true, -Darchive=false, libarchive" |
| 56 | PACKAGECONFIG[dnssd] = "-Ddnssd=true, -Ddnssd=false, avahi" |
| 57 | PACKAGECONFIG[gcr] = "-Dgcr=true, -Dgcr=false, gcr" |
| 58 | PACKAGECONFIG[http] = "-Dhttp=true, -Dhttp=false, libsoup-2.4" |
| 59 | PACKAGECONFIG[libmtp] = "-Dmtp=true, -Dmtp=false, libmtp" |
| 60 | PACKAGECONFIG[logind] = "-Dlogind=true, -Dlogind=false, systemd" |
| 61 | PACKAGECONFIG[libgphoto2] = "-Dgphoto2=true, -Dgphoto2=false, libgphoto2" |
| 62 | PACKAGECONFIG[samba] = "-Dsmb=true, -Dsmb=false, samba" |
| 63 | PACKAGECONFIG[systemd] = "-Dsystemduserunitdir=${systemd_user_unitdir} -Dtmpfilesdir=${libdir}/tmpfiles.d, -Dsystemduserunitdir=no -Dtmpfilesdir=no, systemd" |
| 64 | |
| 65 | # needs meta-filesystems |
Andrew Geissler | d688a01 | 2020-09-18 13:36:00 -0500 | [diff] [blame] | 66 | PACKAGECONFIG[fuse] = "-Dfuse=true, -Dfuse=false, fuse3" |
Brad Bishop | 1932369 | 2019-04-05 15:28:33 -0400 | [diff] [blame] | 67 | |
| 68 | # libcdio-paranoia recipe doesn't exist yet |
| 69 | PACKAGECONFIG[cdda] = "-Dcdda=true, -Dcdda=false, libcdio-paranoia" |
| 70 | |
Brad Bishop | e42b3e3 | 2020-01-15 22:08:42 -0500 | [diff] [blame] | 71 | USERADD_PACKAGES = "${PN}" |
Patrick Williams | 213cb26 | 2021-08-07 19:21:33 -0500 | [diff] [blame] | 72 | USERADD_PARAM:${PN} = "--system --no-create-home --user-group --home-dir ${sysconfdir}/${BPN}-1 polkitd" |
Brad Bishop | e42b3e3 | 2020-01-15 22:08:42 -0500 | [diff] [blame] | 73 | |
Patrick Williams | 213cb26 | 2021-08-07 19:21:33 -0500 | [diff] [blame] | 74 | do_install:append() { |
Brad Bishop | 26bdd44 | 2019-08-16 17:08:17 -0400 | [diff] [blame] | 75 | if ${@bb.utils.contains('DISTRO_FEATURES', 'polkit', 'true', 'false', d)}; then |
| 76 | # Fix up permissions on polkit rules.d to work with rpm4 constraints |
| 77 | chmod 700 ${D}/${datadir}/polkit-1/rules.d |
| 78 | chown polkitd:root ${D}/${datadir}/polkit-1/rules.d |
| 79 | fi |
Brad Bishop | 34ae600 | 2019-04-08 15:21:03 -0400 | [diff] [blame] | 80 | |
| 81 | # After rebuilds (not from scracth) it can happen that the executables in |
| 82 | # libexec ar missing executable permission flag. Not sure but it came up |
| 83 | # during transition to meson. Looked into build files and logs but could |
| 84 | # not find suspicious |
Brad Bishop | c342db3 | 2019-05-15 21:57:59 -0400 | [diff] [blame] | 85 | for exe in `find ${D}/${libexecdir}`; do |
Brad Bishop | 34ae600 | 2019-04-08 15:21:03 -0400 | [diff] [blame] | 86 | chmod +x $exe |
| 87 | done |
Brad Bishop | 1932369 | 2019-04-05 15:28:33 -0400 | [diff] [blame] | 88 | } |