Brad Bishop | 870eb53 | 2020-01-06 09:44:45 -0500 | [diff] [blame] | 1 | DESCRIPTION = "A module to control Raspberry Pi GPIO channels" |
| 2 | HOMEPAGE = "https://sourceforge.net/projects/raspberry-gpio-python/" |
| 3 | SECTION = "devel/python" |
| 4 | LICENSE = "MIT" |
| 5 | LIC_FILES_CHKSUM = "file://LICENCE.txt;md5=9b95630a648966b142f1a0dcea001cb7" |
| 6 | |
| 7 | PYPI_PACKAGE = "RPi.GPIO" |
| 8 | inherit pypi distutils3 |
| 9 | |
| 10 | SRC_URI += "file://0001-Remove-nested-functions.patch" |
| 11 | SRC_URI[md5sum] = "777617f9dea9a1680f9af43db0cf150e" |
| 12 | SRC_URI[sha256sum] = "7424bc6c205466764f30f666c18187a0824077daf20b295c42f08aea2cb87d3f" |
| 13 | |
| 14 | COMPATIBLE_MACHINE = "^rpi$" |
Andrew Geissler | 19b4e6c | 2020-09-18 13:33:52 -0500 | [diff] [blame] | 15 | |
| 16 | # ignore issues with -fno-common from gcc-10 until it's fixed in upstream: |
| 17 | # https://sourceforge.net/p/raspberry-gpio-python/tickets/187/ |
| 18 | CFLAGS += "-fcommon" |