Andrew Geissler | d1d22e6 | 2020-10-16 10:14:32 -0500 | [diff] [blame] | 1 | SUMMARY = "OpenDNSSEC is a policy-based zone signer that automates the process of keeping track of DNSSEC keys and the signing of zones" |
| 2 | |
| 3 | LICENSE = "BSD" |
| 4 | LIC_FILES_CHKSUM = "file://LICENSE;md5=b041dbe2da80d4efd951393fbba90937" |
| 5 | |
| 6 | DEPENDS = "libxml2 openssl ldns libmicrohttpd jansson libyaml " |
| 7 | |
Andrew Geissler | 8b13928 | 2021-03-05 15:22:30 -0600 | [diff] [blame] | 8 | SRC_URI = "https://dist.opendnssec.org/source/opendnssec-${PV}.tar.gz \ |
Andrew Geissler | d1d22e6 | 2020-10-16 10:14:32 -0500 | [diff] [blame] | 9 | file://libxml2_conf.patch \ |
| 10 | file://libdns_conf_fix.patch \ |
Andrew Geissler | d1d22e6 | 2020-10-16 10:14:32 -0500 | [diff] [blame] | 11 | " |
| 12 | |
Andrew Geissler | a1a6aef | 2021-06-25 14:23:58 -0500 | [diff] [blame] | 13 | SRC_URI[sha256sum] = "6d1d466c8d7f507f3e665f4bfe4d16a68d6bff9d7c2ab65f852e2b2a821c28b5" |
Andrew Geissler | d1d22e6 | 2020-10-16 10:14:32 -0500 | [diff] [blame] | 14 | |
| 15 | inherit autotools pkgconfig perlnative |
| 16 | |
Andrew Geissler | d1d22e6 | 2020-10-16 10:14:32 -0500 | [diff] [blame] | 17 | EXTRA_OECONF = " --with-libxml2=${STAGING_DIR_HOST}/usr --with-ldns=${STAGING_DIR_HOST}/usr \ |
| 18 | --with-ssl=${STAGING_DIR_HOST}/usr " |
| 19 | |
| 20 | CFLAGS += "-fcommon" |
| 21 | |
| 22 | PACKAGECONFIG ?= "sqlite3" |
| 23 | |
| 24 | PACKAGECONFIG[cunit] = "--with-cunit=${STAGING_DIR_HOST}/usr, --without-cunit," |
| 25 | PACKAGECONFIG[sqlite3] = "--with-sqlite3=${STAGING_DIR_HOST}/usr, ,sqlite3, sqlite3" |
| 26 | PACKAGECONFIG[mysql] = "--with-mysql=yes, , mariadb, mariadb" |
| 27 | PACKAGECONFIG[readline] = "--with-readline, --without-readline, readline" |
| 28 | PACKAGECONFIG[unwind] = "--with-libunwind, --without-libunwind" |
| 29 | |
Patrick Williams | 213cb26 | 2021-08-07 19:21:33 -0500 | [diff] [blame] | 30 | do_install:append () { |
Andrew Geissler | d1d22e6 | 2020-10-16 10:14:32 -0500 | [diff] [blame] | 31 | rm -rf ${D}${localstatedir}/run |
| 32 | } |
| 33 | |
Patrick Williams | 213cb26 | 2021-08-07 19:21:33 -0500 | [diff] [blame] | 34 | RDEPENDS:${PN} = "softhsm" |