Patrick Williams | c0f7c04 | 2017-02-23 20:41:17 -0600 | [diff] [blame] | 1 | # This file is part of U-Boot verified boot support and is intended to be |
| 2 | # inherited from u-boot recipe and from kernel-fitimage.bbclass. |
| 3 | # |
| 4 | # The signature procedure requires the user to generate an RSA key and |
| 5 | # certificate in a directory and to define the following variable: |
| 6 | # |
| 7 | # UBOOT_SIGN_KEYDIR = "/keys/directory" |
| 8 | # UBOOT_SIGN_KEYNAME = "dev" # keys name in keydir (eg. "dev.crt", "dev.key") |
| 9 | # UBOOT_MKIMAGE_DTCOPTS = "-I dts -O dtb -p 2000" |
| 10 | # UBOOT_SIGN_ENABLE = "1" |
| 11 | # |
| 12 | # As verified boot depends on fitImage generation, following is also required: |
| 13 | # |
| 14 | # KERNEL_CLASSES ?= " kernel-fitimage " |
| 15 | # KERNEL_IMAGETYPE ?= "fitImage" |
| 16 | # |
| 17 | # The signature support is limited to the use of CONFIG_OF_SEPARATE in U-Boot. |
| 18 | # |
| 19 | # The tasks sequence is set as below, using DEPLOY_IMAGE_DIR as common place to |
| 20 | # treat the device tree blob: |
| 21 | # |
Patrick Williams | 213cb26 | 2021-08-07 19:21:33 -0500 | [diff] [blame] | 22 | # * u-boot:do_install:append |
Brad Bishop | 1932369 | 2019-04-05 15:28:33 -0400 | [diff] [blame] | 23 | # Install UBOOT_DTB_BINARY to datadir, so that kernel can use it for |
| 24 | # signing, and kernel will deploy UBOOT_DTB_BINARY after signs it. |
| 25 | # |
| 26 | # * virtual/kernel:do_assemble_fitimage |
| 27 | # Sign the image |
| 28 | # |
| 29 | # * u-boot:do_deploy[postfuncs] |
| 30 | # Deploy files like UBOOT_DTB_IMAGE, UBOOT_DTB_SYMLINK and others. |
Patrick Williams | c0f7c04 | 2017-02-23 20:41:17 -0600 | [diff] [blame] | 31 | # |
Brad Bishop | 6e60e8b | 2018-02-01 10:27:11 -0500 | [diff] [blame] | 32 | # For more details on signature process, please refer to U-Boot documentation. |
Patrick Williams | c0f7c04 | 2017-02-23 20:41:17 -0600 | [diff] [blame] | 33 | |
Andrew Geissler | 3b8a17c | 2021-04-15 15:55:55 -0500 | [diff] [blame] | 34 | # We need some variables from u-boot-config |
| 35 | inherit uboot-config |
| 36 | |
| 37 | # Enable use of a U-Boot fitImage |
| 38 | UBOOT_FITIMAGE_ENABLE ?= "0" |
| 39 | |
| 40 | # Signature activation - these require their respective fitImages |
Patrick Williams | c0f7c04 | 2017-02-23 20:41:17 -0600 | [diff] [blame] | 41 | UBOOT_SIGN_ENABLE ?= "0" |
Andrew Geissler | 3b8a17c | 2021-04-15 15:55:55 -0500 | [diff] [blame] | 42 | SPL_SIGN_ENABLE ?= "0" |
Patrick Williams | c0f7c04 | 2017-02-23 20:41:17 -0600 | [diff] [blame] | 43 | |
| 44 | # Default value for deployment filenames. |
| 45 | UBOOT_DTB_IMAGE ?= "u-boot-${MACHINE}-${PV}-${PR}.dtb" |
| 46 | UBOOT_DTB_BINARY ?= "u-boot.dtb" |
| 47 | UBOOT_DTB_SYMLINK ?= "u-boot-${MACHINE}.dtb" |
Andrew Geissler | 3b8a17c | 2021-04-15 15:55:55 -0500 | [diff] [blame] | 48 | UBOOT_NODTB_IMAGE ?= "u-boot-nodtb-${MACHINE}-${PV}-${PR}.bin" |
| 49 | UBOOT_NODTB_BINARY ?= "u-boot-nodtb.bin" |
| 50 | UBOOT_NODTB_SYMLINK ?= "u-boot-nodtb-${MACHINE}.bin" |
| 51 | UBOOT_ITS_IMAGE ?= "u-boot-its-${MACHINE}-${PV}-${PR}" |
| 52 | UBOOT_ITS ?= "u-boot.its" |
| 53 | UBOOT_ITS_SYMLINK ?= "u-boot-its-${MACHINE}" |
| 54 | UBOOT_FITIMAGE_IMAGE ?= "u-boot-fitImage-${MACHINE}-${PV}-${PR}" |
| 55 | UBOOT_FITIMAGE_BINARY ?= "u-boot-fitImage" |
| 56 | UBOOT_FITIMAGE_SYMLINK ?= "u-boot-fitImage-${MACHINE}" |
| 57 | SPL_DIR ?= "spl" |
| 58 | SPL_DTB_IMAGE ?= "u-boot-spl-${MACHINE}-${PV}-${PR}.dtb" |
| 59 | SPL_DTB_BINARY ?= "u-boot-spl.dtb" |
| 60 | SPL_DTB_SYMLINK ?= "u-boot-spl-${MACHINE}.dtb" |
| 61 | SPL_NODTB_IMAGE ?= "u-boot-spl-nodtb-${MACHINE}-${PV}-${PR}.bin" |
| 62 | SPL_NODTB_BINARY ?= "u-boot-spl-nodtb.bin" |
| 63 | SPL_NODTB_SYMLINK ?= "u-boot-spl-nodtb-${MACHINE}.bin" |
Patrick Williams | c0f7c04 | 2017-02-23 20:41:17 -0600 | [diff] [blame] | 64 | |
Andrew Geissler | 3b8a17c | 2021-04-15 15:55:55 -0500 | [diff] [blame] | 65 | # U-Boot fitImage description |
| 66 | UBOOT_FIT_DESC ?= "U-Boot fitImage for ${DISTRO_NAME}/${PV}/${MACHINE}" |
| 67 | |
| 68 | # Kernel / U-Boot fitImage Hash Algo |
| 69 | FIT_HASH_ALG ?= "sha256" |
| 70 | UBOOT_FIT_HASH_ALG ?= "sha256" |
| 71 | |
| 72 | # Kernel / U-Boot fitImage Signature Algo |
| 73 | FIT_SIGN_ALG ?= "rsa2048" |
| 74 | UBOOT_FIT_SIGN_ALG ?= "rsa2048" |
| 75 | |
| 76 | # Generate keys for signing Kernel / U-Boot fitImage |
| 77 | FIT_GENERATE_KEYS ?= "0" |
| 78 | UBOOT_FIT_GENERATE_KEYS ?= "0" |
| 79 | |
| 80 | # Size of private keys in number of bits |
| 81 | FIT_SIGN_NUMBITS ?= "2048" |
| 82 | UBOOT_FIT_SIGN_NUMBITS ?= "2048" |
| 83 | |
| 84 | # args to openssl genrsa (Default is just the public exponent) |
| 85 | FIT_KEY_GENRSA_ARGS ?= "-F4" |
| 86 | UBOOT_FIT_KEY_GENRSA_ARGS ?= "-F4" |
| 87 | |
| 88 | # args to openssl req (Default is -batch for non interactive mode and |
| 89 | # -new for new certificate) |
| 90 | FIT_KEY_REQ_ARGS ?= "-batch -new" |
| 91 | UBOOT_FIT_KEY_REQ_ARGS ?= "-batch -new" |
| 92 | |
| 93 | # Standard format for public key certificate |
| 94 | FIT_KEY_SIGN_PKCS ?= "-x509" |
| 95 | UBOOT_FIT_KEY_SIGN_PKCS ?= "-x509" |
| 96 | |
| 97 | # Functions on this bbclass can apply to either U-boot or Kernel, |
| 98 | # depending on the scenario |
Brad Bishop | 1932369 | 2019-04-05 15:28:33 -0400 | [diff] [blame] | 99 | UBOOT_PN = "${@d.getVar('PREFERRED_PROVIDER_u-boot') or 'u-boot'}" |
Andrew Geissler | 3b8a17c | 2021-04-15 15:55:55 -0500 | [diff] [blame] | 100 | KERNEL_PN = "${@d.getVar('PREFERRED_PROVIDER_virtual/kernel')}" |
| 101 | |
| 102 | # We need u-boot-tools-native if we're creating a U-Boot fitImage |
| 103 | python() { |
| 104 | if d.getVar('UBOOT_FITIMAGE_ENABLE') == '1': |
| 105 | depends = d.getVar("DEPENDS") |
| 106 | depends = "%s u-boot-tools-native dtc-native" % depends |
| 107 | d.setVar("DEPENDS", depends) |
| 108 | } |
Patrick Williams | c0f7c04 | 2017-02-23 20:41:17 -0600 | [diff] [blame] | 109 | |
Brad Bishop | c342db3 | 2019-05-15 21:57:59 -0400 | [diff] [blame] | 110 | concat_dtb_helper() { |
| 111 | if [ -e "${UBOOT_DTB_BINARY}" ]; then |
| 112 | ln -sf ${UBOOT_DTB_IMAGE} ${DEPLOYDIR}/${UBOOT_DTB_BINARY} |
| 113 | ln -sf ${UBOOT_DTB_IMAGE} ${DEPLOYDIR}/${UBOOT_DTB_SYMLINK} |
| 114 | fi |
| 115 | |
| 116 | if [ -f "${UBOOT_NODTB_BINARY}" ]; then |
| 117 | install ${UBOOT_NODTB_BINARY} ${DEPLOYDIR}/${UBOOT_NODTB_IMAGE} |
| 118 | ln -sf ${UBOOT_NODTB_IMAGE} ${DEPLOYDIR}/${UBOOT_NODTB_SYMLINK} |
| 119 | ln -sf ${UBOOT_NODTB_IMAGE} ${DEPLOYDIR}/${UBOOT_NODTB_BINARY} |
| 120 | fi |
| 121 | |
Andrew Geissler | 3b8a17c | 2021-04-15 15:55:55 -0500 | [diff] [blame] | 122 | # If we're not using a signed u-boot fit, concatenate SPL w/o DTB & U-Boot DTB |
| 123 | # with public key (otherwise it will be deployed by the equivalent |
| 124 | # concat_spl_dtb_helper function - cf. kernel-fitimage.bbclass for more details) |
| 125 | if [ "${SPL_SIGN_ENABLE}" != "1" ] ; then |
| 126 | deployed_uboot_dtb_binary='${DEPLOY_DIR_IMAGE}/${UBOOT_DTB_IMAGE}' |
| 127 | if [ "x${UBOOT_SUFFIX}" = "ximg" -o "x${UBOOT_SUFFIX}" = "xrom" ] && \ |
| 128 | [ -e "$deployed_uboot_dtb_binary" ]; then |
| 129 | oe_runmake EXT_DTB=$deployed_uboot_dtb_binary |
| 130 | install ${UBOOT_BINARY} ${DEPLOYDIR}/${UBOOT_IMAGE} |
| 131 | elif [ -e "${DEPLOYDIR}/${UBOOT_NODTB_IMAGE}" -a -e "$deployed_uboot_dtb_binary" ]; then |
| 132 | cd ${DEPLOYDIR} |
| 133 | cat ${UBOOT_NODTB_IMAGE} $deployed_uboot_dtb_binary | tee ${B}/${CONFIG_B_PATH}/${UBOOT_BINARY} > ${UBOOT_IMAGE} |
| 134 | else |
| 135 | bbwarn "Failure while adding public key to u-boot binary. Verified boot won't be available." |
| 136 | fi |
Brad Bishop | c342db3 | 2019-05-15 21:57:59 -0400 | [diff] [blame] | 137 | fi |
| 138 | } |
| 139 | |
Andrew Geissler | 3b8a17c | 2021-04-15 15:55:55 -0500 | [diff] [blame] | 140 | concat_spl_dtb_helper() { |
| 141 | |
| 142 | # We only deploy symlinks to the u-boot-spl.dtb,as the KERNEL_PN will |
| 143 | # be responsible for deploying the real file |
| 144 | if [ -e "${SPL_DIR}/${SPL_DTB_BINARY}" ] ; then |
| 145 | ln -sf ${SPL_DTB_IMAGE} ${DEPLOYDIR}/${SPL_DTB_SYMLINK} |
| 146 | ln -sf ${SPL_DTB_IMAGE} ${DEPLOYDIR}/${SPL_DTB_BINARY} |
| 147 | fi |
| 148 | |
| 149 | # Concatenate the SPL nodtb binary and u-boot.dtb |
| 150 | deployed_spl_dtb_binary='${DEPLOY_DIR_IMAGE}/${SPL_DTB_IMAGE}' |
| 151 | if [ -e "${DEPLOYDIR}/${SPL_NODTB_IMAGE}" -a -e "$deployed_spl_dtb_binary" ] ; then |
| 152 | cd ${DEPLOYDIR} |
| 153 | cat ${SPL_NODTB_IMAGE} $deployed_spl_dtb_binary | tee ${B}/${CONFIG_B_PATH}/${SPL_BINARY} > ${SPL_IMAGE} |
| 154 | else |
| 155 | bbwarn "Failure while adding public key to spl binary. Verified U-Boot boot won't be available." |
| 156 | fi |
| 157 | } |
| 158 | |
| 159 | |
Brad Bishop | 1932369 | 2019-04-05 15:28:33 -0400 | [diff] [blame] | 160 | concat_dtb() { |
Brad Bishop | c342db3 | 2019-05-15 21:57:59 -0400 | [diff] [blame] | 161 | if [ "${UBOOT_SIGN_ENABLE}" = "1" -a "${PN}" = "${UBOOT_PN}" -a -n "${UBOOT_DTB_BINARY}" ]; then |
Brad Bishop | 1932369 | 2019-04-05 15:28:33 -0400 | [diff] [blame] | 162 | mkdir -p ${DEPLOYDIR} |
Brad Bishop | c342db3 | 2019-05-15 21:57:59 -0400 | [diff] [blame] | 163 | if [ -n "${UBOOT_CONFIG}" ]; then |
| 164 | for config in ${UBOOT_MACHINE}; do |
Brad Bishop | 96ff198 | 2019-08-19 13:50:42 -0400 | [diff] [blame] | 165 | CONFIG_B_PATH="${config}" |
Brad Bishop | c342db3 | 2019-05-15 21:57:59 -0400 | [diff] [blame] | 166 | cd ${B}/${config} |
| 167 | concat_dtb_helper |
| 168 | done |
| 169 | else |
Brad Bishop | 96ff198 | 2019-08-19 13:50:42 -0400 | [diff] [blame] | 170 | CONFIG_B_PATH="" |
Patrick Williams | c0f7c04 | 2017-02-23 20:41:17 -0600 | [diff] [blame] | 171 | cd ${B} |
Brad Bishop | c342db3 | 2019-05-15 21:57:59 -0400 | [diff] [blame] | 172 | concat_dtb_helper |
Patrick Williams | c0f7c04 | 2017-02-23 20:41:17 -0600 | [diff] [blame] | 173 | fi |
| 174 | fi |
| 175 | } |
| 176 | |
Andrew Geissler | 3b8a17c | 2021-04-15 15:55:55 -0500 | [diff] [blame] | 177 | concat_spl_dtb() { |
| 178 | if [ "${SPL_SIGN_ENABLE}" = "1" -a "${PN}" = "${UBOOT_PN}" -a -n "${SPL_DTB_BINARY}" ]; then |
| 179 | mkdir -p ${DEPLOYDIR} |
| 180 | if [ -n "${UBOOT_CONFIG}" ]; then |
| 181 | for config in ${UBOOT_MACHINE}; do |
| 182 | CONFIG_B_PATH="${config}" |
| 183 | cd ${B}/${config} |
| 184 | concat_spl_dtb_helper |
| 185 | done |
| 186 | else |
| 187 | CONFIG_B_PATH="" |
| 188 | cd ${B} |
| 189 | concat_spl_dtb_helper |
| 190 | fi |
| 191 | fi |
| 192 | } |
| 193 | |
| 194 | |
Brad Bishop | 1932369 | 2019-04-05 15:28:33 -0400 | [diff] [blame] | 195 | # Install UBOOT_DTB_BINARY to datadir, so that kernel can use it for |
| 196 | # signing, and kernel will deploy UBOOT_DTB_BINARY after signs it. |
Brad Bishop | c342db3 | 2019-05-15 21:57:59 -0400 | [diff] [blame] | 197 | install_helper() { |
| 198 | if [ -f "${UBOOT_DTB_BINARY}" ]; then |
Brad Bishop | c342db3 | 2019-05-15 21:57:59 -0400 | [diff] [blame] | 199 | # UBOOT_DTB_BINARY is a symlink to UBOOT_DTB_IMAGE, so we |
| 200 | # need both of them. |
Andrew Geissler | 0903674 | 2021-06-25 14:25:14 -0500 | [diff] [blame] | 201 | install -Dm 0644 ${UBOOT_DTB_BINARY} ${D}${datadir}/${UBOOT_DTB_IMAGE} |
Brad Bishop | c342db3 | 2019-05-15 21:57:59 -0400 | [diff] [blame] | 202 | ln -sf ${UBOOT_DTB_IMAGE} ${D}${datadir}/${UBOOT_DTB_BINARY} |
| 203 | else |
| 204 | bbwarn "${UBOOT_DTB_BINARY} not found" |
| 205 | fi |
| 206 | } |
| 207 | |
Andrew Geissler | 3b8a17c | 2021-04-15 15:55:55 -0500 | [diff] [blame] | 208 | # Install SPL dtb and u-boot nodtb to datadir, |
| 209 | install_spl_helper() { |
| 210 | if [ -f "${SPL_DIR}/${SPL_DTB_BINARY}" ]; then |
Andrew Geissler | 0903674 | 2021-06-25 14:25:14 -0500 | [diff] [blame] | 211 | install -Dm 0644 ${SPL_DIR}/${SPL_DTB_BINARY} ${D}${datadir}/${SPL_DTB_IMAGE} |
Andrew Geissler | 3b8a17c | 2021-04-15 15:55:55 -0500 | [diff] [blame] | 212 | ln -sf ${SPL_DTB_IMAGE} ${D}${datadir}/${SPL_DTB_BINARY} |
| 213 | else |
| 214 | bbwarn "${SPL_DTB_BINARY} not found" |
| 215 | fi |
| 216 | if [ -f "${UBOOT_NODTB_BINARY}" ] ; then |
Andrew Geissler | 0903674 | 2021-06-25 14:25:14 -0500 | [diff] [blame] | 217 | install -Dm 0644 ${UBOOT_NODTB_BINARY} ${D}${datadir}/${UBOOT_NODTB_IMAGE} |
Andrew Geissler | 3b8a17c | 2021-04-15 15:55:55 -0500 | [diff] [blame] | 218 | ln -sf ${UBOOT_NODTB_IMAGE} ${D}${datadir}/${UBOOT_NODTB_BINARY} |
| 219 | else |
| 220 | bbwarn "${UBOOT_NODTB_BINARY} not found" |
| 221 | fi |
| 222 | |
| 223 | # We need to install a 'stub' u-boot-fitimage + its to datadir, |
| 224 | # so that the KERNEL_PN can use the correct filename when |
| 225 | # assembling and deploying them |
| 226 | touch ${D}/${datadir}/${UBOOT_FITIMAGE_IMAGE} |
| 227 | touch ${D}/${datadir}/${UBOOT_ITS_IMAGE} |
| 228 | } |
| 229 | |
Patrick Williams | 213cb26 | 2021-08-07 19:21:33 -0500 | [diff] [blame] | 230 | do_install:append() { |
Andrew Geissler | 3b8a17c | 2021-04-15 15:55:55 -0500 | [diff] [blame] | 231 | if [ "${PN}" = "${UBOOT_PN}" ]; then |
Brad Bishop | c342db3 | 2019-05-15 21:57:59 -0400 | [diff] [blame] | 232 | if [ -n "${UBOOT_CONFIG}" ]; then |
| 233 | for config in ${UBOOT_MACHINE}; do |
| 234 | cd ${B}/${config} |
Andrew Geissler | 3b8a17c | 2021-04-15 15:55:55 -0500 | [diff] [blame] | 235 | if [ "${UBOOT_SIGN_ENABLE}" = "1" -o "${UBOOT_FITIMAGE_ENABLE}" = "1" ] && \ |
| 236 | [ -n "${UBOOT_DTB_BINARY}" ]; then |
| 237 | install_helper |
| 238 | fi |
| 239 | if [ "${SPL_SIGN_ENABLE}" = "1" -a -n "${SPL_DTB_BINARY}" ]; then |
| 240 | install_spl_helper |
| 241 | fi |
Brad Bishop | c342db3 | 2019-05-15 21:57:59 -0400 | [diff] [blame] | 242 | done |
| 243 | else |
| 244 | cd ${B} |
Andrew Geissler | 3b8a17c | 2021-04-15 15:55:55 -0500 | [diff] [blame] | 245 | if [ "${UBOOT_SIGN_ENABLE}" = "1" -o "${UBOOT_FITIMAGE_ENABLE}" = "1" ] && \ |
| 246 | [ -n "${UBOOT_DTB_BINARY}" ]; then |
| 247 | install_helper |
| 248 | fi |
| 249 | if [ "${UBOOT_FITIMAGE_ENABLE}" = "1" -a -n "${SPL_DTB_BINARY}" ]; then |
| 250 | install_spl_helper |
| 251 | fi |
Brad Bishop | 1932369 | 2019-04-05 15:28:33 -0400 | [diff] [blame] | 252 | fi |
| 253 | fi |
| 254 | } |
| 255 | |
William A. Kennington III | ac69b48 | 2021-06-02 12:28:27 -0700 | [diff] [blame] | 256 | do_uboot_generate_rsa_keys() { |
Andrew Geissler | 3b8a17c | 2021-04-15 15:55:55 -0500 | [diff] [blame] | 257 | if [ "${SPL_SIGN_ENABLE}" = "0" ] && [ "${UBOOT_FIT_GENERATE_KEYS}" = "1" ]; then |
| 258 | bbwarn "UBOOT_FIT_GENERATE_KEYS is set to 1 eventhough SPL_SIGN_ENABLE is set to 0. The keys will not be generated as they won't be used." |
| 259 | fi |
| 260 | |
| 261 | if [ "${SPL_SIGN_ENABLE}" = "1" ] && [ "${UBOOT_FIT_GENERATE_KEYS}" = "1" ]; then |
| 262 | |
| 263 | # Generate keys only if they don't already exist |
| 264 | if [ ! -f "${SPL_SIGN_KEYDIR}/${SPL_SIGN_KEYNAME}".key ] || \ |
| 265 | [ ! -f "${SPL_SIGN_KEYDIR}/${SPL_SIGN_KEYNAME}".crt ]; then |
| 266 | |
| 267 | # make directory if it does not already exist |
| 268 | mkdir -p "${SPL_SIGN_KEYDIR}" |
| 269 | |
| 270 | echo "Generating RSA private key for signing U-Boot fitImage" |
| 271 | openssl genrsa ${UBOOT_FIT_KEY_GENRSA_ARGS} -out \ |
| 272 | "${SPL_SIGN_KEYDIR}/${SPL_SIGN_KEYNAME}".key \ |
| 273 | "${UBOOT_FIT_SIGN_NUMBITS}" |
| 274 | |
| 275 | echo "Generating certificate for signing U-Boot fitImage" |
| 276 | openssl req ${FIT_KEY_REQ_ARGS} "${UBOOT_FIT_KEY_SIGN_PKCS}" \ |
| 277 | -key "${SPL_SIGN_KEYDIR}/${SPL_SIGN_KEYNAME}".key \ |
| 278 | -out "${SPL_SIGN_KEYDIR}/${SPL_SIGN_KEYNAME}".crt |
| 279 | fi |
| 280 | fi |
| 281 | |
| 282 | } |
| 283 | |
William A. Kennington III | ac69b48 | 2021-06-02 12:28:27 -0700 | [diff] [blame] | 284 | addtask uboot_generate_rsa_keys before do_uboot_assemble_fitimage after do_compile |
Andrew Geissler | 3b8a17c | 2021-04-15 15:55:55 -0500 | [diff] [blame] | 285 | |
| 286 | # Create a ITS file for the U-boot FIT, for use when |
| 287 | # we want to sign it so that the SPL can verify it |
| 288 | uboot_fitimage_assemble() { |
| 289 | uboot_its="${1}" |
| 290 | uboot_nodtb_bin="${2}" |
| 291 | uboot_dtb="${3}" |
| 292 | uboot_bin="${4}" |
| 293 | spl_dtb="${5}" |
| 294 | uboot_csum="${UBOOT_FIT_HASH_ALG}" |
| 295 | uboot_sign_algo="${UBOOT_FIT_SIGN_ALG}" |
| 296 | uboot_sign_keyname="${SPL_SIGN_KEYNAME}" |
| 297 | |
| 298 | rm -f ${uboot_its} ${uboot_bin} |
| 299 | |
| 300 | # First we create the ITS script |
| 301 | cat << EOF >> ${uboot_its} |
| 302 | /dts-v1/; |
| 303 | |
| 304 | / { |
| 305 | description = "${UBOOT_FIT_DESC}"; |
| 306 | #address-cells = <1>; |
| 307 | |
| 308 | images { |
| 309 | uboot { |
| 310 | description = "U-Boot image"; |
| 311 | data = /incbin/("${uboot_nodtb_bin}"); |
| 312 | type = "standalone"; |
| 313 | os = "u-boot"; |
| 314 | arch = "${UBOOT_ARCH}"; |
| 315 | compression = "none"; |
| 316 | load = <${UBOOT_LOADADDRESS}>; |
| 317 | entry = <${UBOOT_ENTRYPOINT}>; |
| 318 | EOF |
| 319 | |
| 320 | if [ "${SPL_SIGN_ENABLE}" = "1" ] ; then |
| 321 | cat << EOF >> ${uboot_its} |
| 322 | signature { |
| 323 | algo = "${uboot_csum},${uboot_sign_algo}"; |
| 324 | key-name-hint = "${uboot_sign_keyname}"; |
| 325 | }; |
| 326 | EOF |
| 327 | fi |
| 328 | |
| 329 | cat << EOF >> ${uboot_its} |
| 330 | }; |
| 331 | fdt { |
| 332 | description = "U-Boot FDT"; |
| 333 | data = /incbin/("${uboot_dtb}"); |
| 334 | type = "flat_dt"; |
| 335 | arch = "${UBOOT_ARCH}"; |
| 336 | compression = "none"; |
| 337 | EOF |
| 338 | |
| 339 | if [ "${SPL_SIGN_ENABLE}" = "1" ] ; then |
| 340 | cat << EOF >> ${uboot_its} |
| 341 | signature { |
| 342 | algo = "${uboot_csum},${uboot_sign_algo}"; |
| 343 | key-name-hint = "${uboot_sign_keyname}"; |
| 344 | }; |
| 345 | EOF |
| 346 | fi |
| 347 | |
| 348 | cat << EOF >> ${uboot_its} |
| 349 | }; |
| 350 | }; |
| 351 | |
| 352 | configurations { |
| 353 | default = "conf"; |
| 354 | conf { |
| 355 | description = "Boot with signed U-Boot FIT"; |
| 356 | loadables = "uboot"; |
| 357 | fdt = "fdt"; |
| 358 | }; |
| 359 | }; |
| 360 | }; |
| 361 | EOF |
| 362 | |
| 363 | # |
| 364 | # Assemble the U-boot FIT image |
| 365 | # |
| 366 | ${UBOOT_MKIMAGE} \ |
| 367 | ${@'-D "${SPL_MKIMAGE_DTCOPTS}"' if len('${SPL_MKIMAGE_DTCOPTS}') else ''} \ |
| 368 | -f ${uboot_its} \ |
| 369 | ${uboot_bin} |
| 370 | |
| 371 | if [ "${SPL_SIGN_ENABLE}" = "1" ] ; then |
| 372 | # |
| 373 | # Sign the U-boot FIT image and add public key to SPL dtb |
| 374 | # |
| 375 | ${UBOOT_MKIMAGE_SIGN} \ |
| 376 | ${@'-D "${SPL_MKIMAGE_DTCOPTS}"' if len('${SPL_MKIMAGE_DTCOPTS}') else ''} \ |
| 377 | -F -k "${SPL_SIGN_KEYDIR}" \ |
| 378 | -K "${spl_dtb}" \ |
| 379 | -r ${uboot_bin} \ |
| 380 | ${SPL_MKIMAGE_SIGN_ARGS} |
| 381 | fi |
| 382 | |
| 383 | } |
| 384 | |
| 385 | do_uboot_assemble_fitimage() { |
| 386 | # This function runs in KERNEL_PN context. The reason for that is that we need to |
| 387 | # support the scenario where UBOOT_SIGN_ENABLE is placing the Kernel fitImage's |
| 388 | # pubkey in the u-boot.dtb file, so that we can use it when building the U-Boot |
| 389 | # fitImage itself. |
| 390 | if [ "${UBOOT_FITIMAGE_ENABLE}" = "1" ] && \ |
| 391 | [ -n "${SPL_DTB_BINARY}" -a "${PN}" = "${KERNEL_PN}" ] ; then |
| 392 | if [ "${UBOOT_SIGN_ENABLE}" != "1" ]; then |
| 393 | # If we're not signing the Kernel fitImage, that means |
| 394 | # we need to copy the u-boot.dtb from staging ourselves |
| 395 | cp -P ${STAGING_DATADIR}/u-boot*.dtb ${B} |
| 396 | fi |
| 397 | # As we are in the kernel context, we need to copy u-boot-spl.dtb from staging first. |
| 398 | # Unfortunately, need to glob on top of ${SPL_DTB_BINARY} since _IMAGE and _SYMLINK |
| 399 | # will contain U-boot's PV |
| 400 | # Similarly, we need to get the filename for the 'stub' u-boot-fitimage + its in |
| 401 | # staging so that we can use it for creating the image with the correct filename |
| 402 | # in the KERNEL_PN context. |
| 403 | # As for the u-boot.dtb (with fitimage's pubkey), it should come from the dependent |
| 404 | # do_assemble_fitimage task |
| 405 | cp -P ${STAGING_DATADIR}/u-boot-spl*.dtb ${B} |
| 406 | cp -P ${STAGING_DATADIR}/u-boot-nodtb*.bin ${B} |
| 407 | rm -rf ${B}/u-boot-fitImage-* ${B}/u-boot-its-* |
| 408 | kernel_uboot_fitimage_name=`basename ${STAGING_DATADIR}/u-boot-fitImage-*` |
| 409 | kernel_uboot_its_name=`basename ${STAGING_DATADIR}/u-boot-its-*` |
| 410 | cd ${B} |
| 411 | uboot_fitimage_assemble ${kernel_uboot_its_name} ${UBOOT_NODTB_BINARY} \ |
| 412 | ${UBOOT_DTB_BINARY} ${kernel_uboot_fitimage_name} \ |
| 413 | ${SPL_DTB_BINARY} |
| 414 | fi |
| 415 | } |
| 416 | |
| 417 | addtask uboot_assemble_fitimage before do_deploy after do_compile |
| 418 | |
Patrick Williams | 213cb26 | 2021-08-07 19:21:33 -0500 | [diff] [blame] | 419 | do_deploy:prepend:pn-${UBOOT_PN}() { |
Andrew Geissler | 3b8a17c | 2021-04-15 15:55:55 -0500 | [diff] [blame] | 420 | if [ "${UBOOT_SIGN_ENABLE}" = "1" -a -n "${UBOOT_DTB_BINARY}" ] ; then |
Andrew Geissler | 475cb72 | 2020-07-10 16:00:51 -0500 | [diff] [blame] | 421 | concat_dtb |
| 422 | fi |
Andrew Geissler | 3b8a17c | 2021-04-15 15:55:55 -0500 | [diff] [blame] | 423 | |
| 424 | if [ "${UBOOT_FITIMAGE_ENABLE}" = "1" ] ; then |
| 425 | # Deploy the u-boot-nodtb binary and symlinks... |
| 426 | if [ -f "${SPL_DIR}/${SPL_NODTB_BINARY}" ] ; then |
| 427 | echo "Copying u-boot-nodtb binary..." |
| 428 | install -m 0644 ${SPL_DIR}/${SPL_NODTB_BINARY} ${DEPLOYDIR}/${SPL_NODTB_IMAGE} |
| 429 | ln -sf ${SPL_NODTB_IMAGE} ${DEPLOYDIR}/${SPL_NODTB_SYMLINK} |
| 430 | ln -sf ${SPL_NODTB_IMAGE} ${DEPLOYDIR}/${SPL_NODTB_BINARY} |
| 431 | fi |
| 432 | |
| 433 | |
| 434 | # We only deploy the symlinks to the uboot-fitImage and uboot-its |
| 435 | # images, as the KERNEL_PN will take care of deploying the real file |
| 436 | ln -sf ${UBOOT_FITIMAGE_IMAGE} ${DEPLOYDIR}/${UBOOT_FITIMAGE_BINARY} |
| 437 | ln -sf ${UBOOT_FITIMAGE_IMAGE} ${DEPLOYDIR}/${UBOOT_FITIMAGE_SYMLINK} |
| 438 | ln -sf ${UBOOT_ITS_IMAGE} ${DEPLOYDIR}/${UBOOT_ITS} |
| 439 | ln -sf ${UBOOT_ITS_IMAGE} ${DEPLOYDIR}/${UBOOT_ITS_SYMLINK} |
| 440 | fi |
| 441 | |
| 442 | if [ "${SPL_SIGN_ENABLE}" = "1" -a -n "${SPL_DTB_BINARY}" ] ; then |
| 443 | concat_spl_dtb |
| 444 | fi |
| 445 | |
| 446 | |
| 447 | } |
| 448 | |
Patrick Williams | 213cb26 | 2021-08-07 19:21:33 -0500 | [diff] [blame] | 449 | do_deploy:append:pn-${UBOOT_PN}() { |
Andrew Geissler | 3b8a17c | 2021-04-15 15:55:55 -0500 | [diff] [blame] | 450 | # If we're creating a u-boot fitImage, point u-boot.bin |
| 451 | # symlink since it might get used by image recipes |
| 452 | if [ "${UBOOT_FITIMAGE_ENABLE}" = "1" ] ; then |
| 453 | ln -sf ${UBOOT_FITIMAGE_IMAGE} ${DEPLOYDIR}/${UBOOT_BINARY} |
| 454 | ln -sf ${UBOOT_FITIMAGE_IMAGE} ${DEPLOYDIR}/${UBOOT_SYMLINK} |
| 455 | fi |
Andrew Geissler | 475cb72 | 2020-07-10 16:00:51 -0500 | [diff] [blame] | 456 | } |
| 457 | |
Patrick Williams | c0f7c04 | 2017-02-23 20:41:17 -0600 | [diff] [blame] | 458 | python () { |
Andrew Geissler | 3b8a17c | 2021-04-15 15:55:55 -0500 | [diff] [blame] | 459 | if ( (d.getVar('UBOOT_SIGN_ENABLE') == '1' |
| 460 | or d.getVar('UBOOT_FITIMAGE_ENABLE') == '1') |
| 461 | and d.getVar('PN') == d.getVar('UBOOT_PN') |
| 462 | and d.getVar('UBOOT_DTB_BINARY')): |
Patrick Williams | c0f7c04 | 2017-02-23 20:41:17 -0600 | [diff] [blame] | 463 | |
Brad Bishop | 1932369 | 2019-04-05 15:28:33 -0400 | [diff] [blame] | 464 | # Make "bitbake u-boot -cdeploy" deploys the signed u-boot.dtb |
Andrew Geissler | 3b8a17c | 2021-04-15 15:55:55 -0500 | [diff] [blame] | 465 | # and/or the U-Boot fitImage |
| 466 | d.appendVarFlag('do_deploy', 'depends', ' %s:do_deploy' % d.getVar('KERNEL_PN')) |
| 467 | |
| 468 | if d.getVar('UBOOT_FITIMAGE_ENABLE') == '1' and d.getVar('PN') == d.getVar('KERNEL_PN'): |
| 469 | # As the U-Boot fitImage is created by the KERNEL_PN, we need |
| 470 | # to make sure that the u-boot-spl.dtb and u-boot-spl-nodtb.bin |
| 471 | # files are in the staging dir for it's use |
| 472 | d.appendVarFlag('do_uboot_assemble_fitimage', 'depends', ' %s:do_populate_sysroot' % d.getVar('UBOOT_PN')) |
| 473 | |
| 474 | # If the Kernel fitImage is being signed, we need to |
| 475 | # create the U-Boot fitImage after it |
| 476 | if d.getVar('UBOOT_SIGN_ENABLE') == '1': |
| 477 | d.appendVarFlag('do_uboot_assemble_fitimage', 'depends', ' %s:do_assemble_fitimage' % d.getVar('KERNEL_PN')) |
| 478 | d.appendVarFlag('do_uboot_assemble_fitimage', 'depends', ' %s:do_assemble_fitimage_initramfs' % d.getVar('KERNEL_PN')) |
| 479 | |
Patrick Williams | c0f7c04 | 2017-02-23 20:41:17 -0600 | [diff] [blame] | 480 | } |