Andrew Geissler | 82c905d | 2020-04-13 13:39:40 -0500 | [diff] [blame] | 1 | SUMMARY = "A simple wrapper around optparse for powerful command line utilities." |
| 2 | DESCRIPTION = "\ |
| 3 | Click is a Python package for creating beautiful command line interfaces \ |
| 4 | in a composable way with as little code as necessary. It's the "Command \ |
| 5 | Line Interface Creation Kit". It's highly configurable but comes with \ |
| 6 | sensible defaults out of the box." |
| 7 | HOMEPAGE = "http://click.pocoo.org/" |
| 8 | LICENSE = "BSD-3-Clause" |
Andrew Geissler | eafcbb8 | 2020-06-05 17:59:17 -0500 | [diff] [blame] | 9 | LIC_FILES_CHKSUM = "file://LICENSE.rst;md5=1fa98232fd645608937a0fdc82e999b8" |
Andrew Geissler | 82c905d | 2020-04-13 13:39:40 -0500 | [diff] [blame] | 10 | |
Andrew Geissler | eafcbb8 | 2020-06-05 17:59:17 -0500 | [diff] [blame] | 11 | SRC_URI[md5sum] = "53692f62cb99a1a10c59248f1776d9c0" |
| 12 | SRC_URI[sha256sum] = "d2b5255c7c6349bc1bd1e59e08cd12acbbd63ce649f2588755783aa94dfb6b1a" |
Andrew Geissler | 82c905d | 2020-04-13 13:39:40 -0500 | [diff] [blame] | 13 | |
Andrew Geissler | d221e03 | 2020-07-10 16:13:21 -0500 | [diff] [blame] | 14 | inherit pypi setuptools3 ptest |
| 15 | |
| 16 | SRC_URI += " \ |
| 17 | file://run-ptest \ |
| 18 | " |
| 19 | |
| 20 | RDEPENDS_${PN}-ptest += " \ |
| 21 | ${PYTHON_PN}-pytest \ |
| 22 | ${PYTHON_PN}-terminal \ |
| 23 | ${PYTHON_PN}-unixadmin \ |
| 24 | " |
| 25 | |
| 26 | do_install_ptest() { |
| 27 | install -d ${D}${PTEST_PATH}/tests |
| 28 | cp -rf ${S}/tests/* ${D}${PTEST_PATH}/tests/ |
| 29 | } |
Andrew Geissler | 82c905d | 2020-04-13 13:39:40 -0500 | [diff] [blame] | 30 | |
| 31 | UPSTREAM_CHECK_REGEX = "click/(?P<pver>\d+(\.\d+)+)/" |
| 32 | |
| 33 | CLEANBROKEN = "1" |
| 34 | |
| 35 | RDEPENDS_${PN} += "\ |
| 36 | ${PYTHON_PN}-io \ |
| 37 | ${PYTHON_PN}-threading \ |
| 38 | " |
| 39 | |
| 40 | BBCLASSEXTEND = "native nativesdk" |