blob: 7bc0d1d00c9ecb5bb80fecfa55af68276b05b7db [file] [log] [blame]
Andrew Geisslerbffdb3e2020-08-21 16:13:29 -05001SUMMARY = "IPython: Productive Interactive Computing"
2HOMEPAGE = "https://ipython.org"
3AUTHOR = "The IPython Development Team <ipython-dev@python.org>"
4LICENSE = "BSD"
5LIC_FILES_CHKSUM = "file://COPYING.rst;md5=59b20262b8663cdd094005bddf47af5f"
6
7PYPI_PACKAGE = "ipython"
8
Andrew Geissler32b11992021-03-31 13:37:05 -05009SRC_URI[sha256sum] = "9c900332d4c5a6de534b4befeeb7de44ad0cc42e8327fa41b7685abde58cec74"
Andrew Geisslerbffdb3e2020-08-21 16:13:29 -050010
11RDEPENDS_${PN} = "\
12 ${PYTHON_PN}-setuptools \
13 ${PYTHON_PN}-jedi \
14 ${PYTHON_PN}-decorator \
15 ${PYTHON_PN}-pickleshare \
16 ${PYTHON_PN}-traitlets \
17 ${PYTHON_PN}-prompt-toolkit \
18 ${PYTHON_PN}-pygments \
19 ${PYTHON_PN}-backcall \
20 ${PYTHON_PN}-pydoc \
21 ${PYTHON_PN}-debugger \
22 ${PYTHON_PN}-pexpect \
23 ${PYTHON_PN}-unixadmin \
24 ${PYTHON_PN}-misc \
25 ${PYTHON_PN}-sqlite3 \
26"
27
28inherit setuptools3 pypi