blob: a4cc05c947918287664005be1a31a8d0ef729bf8 [file] [log] [blame]
Andrew Geisslerc87764f2020-06-27 00:16:32 -05001SUMMARY = "Resolve JSON Pointers in Python"
2HOMEPAGE = "https://github.com/stefankoegl/python-json-pointer"
3LICENSE = "BSD-3-Clause"
4LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=32b15c843b7a329130f4e266a281ebb3"
5
6inherit pypi ptest setuptools3
7
Andrew Geissler32b11992021-03-31 13:37:05 -05008SRC_URI[sha256sum] = "5a34b698db1eb79ceac454159d3f7c12a451a91f6334a4f638454327b7a89962"
Andrew Geisslerc87764f2020-06-27 00:16:32 -05009
10RDEPENDS_${PN} += " \
11 ${PYTHON_PN}-json \
12"
13
14BBCLASSEXTEND = "native nativesdk"
15
16SRC_URI += " \
17 file://run-ptest \
18"
19
20RDEPENDS_${PN}-ptest += " \
21 ${PYTHON_PN}-pytest \
22"
23
24do_install_ptest() {
25 cp -f ${S}/tests.py ${D}${PTEST_PATH}/
26}