Andrew Geissler | d221e03 | 2020-07-10 16:13:21 -0500 | [diff] [blame] | 1 | SUMMARY = "Seamless operability between C++11 and Python" |
| 2 | HOMEPAGE = "https://github.com/wjakob/pybind11" |
| 3 | LICENSE = "BSD-2-Clause" |
Andrew Geissler | ac970dd | 2021-02-12 15:32:45 -0600 | [diff] [blame] | 4 | LIC_FILES_CHKSUM = "file://LICENSE;md5=774f65abd8a7fe3124be2cdf766cd06f" |
Andrew Geissler | d221e03 | 2020-07-10 16:13:21 -0500 | [diff] [blame] | 5 | |
Andrew Geissler | 748a483 | 2020-07-24 16:24:21 -0500 | [diff] [blame] | 6 | DEPENDS = "boost" |
Andrew Geissler | d221e03 | 2020-07-10 16:13:21 -0500 | [diff] [blame] | 7 | |
Andrew Geissler | 748a483 | 2020-07-24 16:24:21 -0500 | [diff] [blame] | 8 | SRC_URI = "git://github.com/pybind/pybind11.git \ |
| 9 | file://0001-Do-not-strip-binaries.patch \ |
| 10 | file://0001-Do-not-check-pointer-size-when-cross-compiling.patch \ |
Andrew Geissler | ac970dd | 2021-02-12 15:32:45 -0600 | [diff] [blame] | 11 | " |
| 12 | SRCREV = "8de7772cc72daca8e947b79b83fea46214931604" |
Andrew Geissler | 748a483 | 2020-07-24 16:24:21 -0500 | [diff] [blame] | 13 | |
| 14 | S = "${WORKDIR}/git" |
| 15 | |
| 16 | BBCLASSEXTEND = "native" |
| 17 | |
| 18 | EXTRA_OECMAKE = "-DPYBIND11_TEST=OFF" |
| 19 | |
Andrew Geissler | bffdb3e | 2020-08-21 16:13:29 -0500 | [diff] [blame] | 20 | inherit cmake setuptools3 python3native |
| 21 | |
| 22 | do_configure() { |
| 23 | cmake_do_configure |
| 24 | } |
| 25 | |
| 26 | do_compile() { |
| 27 | distutils3_do_compile |
| 28 | cmake_do_compile |
| 29 | } |
| 30 | |
| 31 | do_install() { |
| 32 | distutils3_do_install |
| 33 | cmake_do_install |
| 34 | } |
Andrew Geissler | a2681d9 | 2020-10-16 10:17:07 -0500 | [diff] [blame] | 35 | |
| 36 | BBCLASSEXTEND = "native nativesdk" |