Brad Bishop | 6e60e8b | 2018-02-01 10:27:11 -0500 | [diff] [blame] | 1 | SUMMARY = "Utility for IPMI control" |
| 2 | DESCRIPTION = "This package contains a utility for interfacing with devices that support \ |
| 3 | the Intelligent Platform Management Interface specification. IPMI is \ |
| 4 | an open standard for machine health, inventory, and remote power control. \ |
| 5 | \ |
| 6 | This utility can communicate with IPMI-enabled devices through either a \ |
| 7 | kernel driver such as OpenIPMI or over the RMCP LAN protocol defined in \ |
| 8 | the IPMI specification. IPMIv2 adds support for encrypted LAN \ |
| 9 | communications and remote Serial-over-LAN functionality. \ |
| 10 | \ |
| 11 | It provides commands for reading the Sensor Data Repository (SDR) and \ |
| 12 | displaying sensor values, displaying the contents of the System Event \ |
| 13 | Log (SEL), printing Field Replaceable Unit (FRU) information, reading and \ |
| 14 | setting LAN configuration, and chassis power control. \ |
| 15 | " |
| 16 | |
Andrew Geissler | 3eeda90 | 2023-05-19 10:14:02 -0500 | [diff] [blame] | 17 | HOMEPAGE = "http://codeberg.org/IPMITool/ipmitool" |
Brad Bishop | 6e60e8b | 2018-02-01 10:27:11 -0500 | [diff] [blame] | 18 | SECTION = "kernel/userland" |
| 19 | |
| 20 | LICENSE = "BSD-3-Clause" |
| 21 | LIC_FILES_CHKSUM = "file://COPYING;md5=9aa91e13d644326bf281924212862184" |
| 22 | |
| 23 | DEPENDS = "openssl readline ncurses" |
Andrew Geissler | 87f5cff | 2022-09-30 13:13:31 -0500 | [diff] [blame] | 24 | SRCREV = "19d78782d795d0cf4ceefe655f616210c9143e62" |
Andrew Geissler | 3eeda90 | 2023-05-19 10:14:02 -0500 | [diff] [blame] | 25 | SRC_URI = "git://codeberg.org/ipmitool/ipmitool;protocol=https;branch=master \ |
Andrew Geissler | 87f5cff | 2022-09-30 13:13:31 -0500 | [diff] [blame] | 26 | ${IANA_ENTERPRISE_NUMBERS} \ |
Andrew Geissler | 87f5cff | 2022-09-30 13:13:31 -0500 | [diff] [blame] | 27 | file://0001-configure-Remove-the-logic-to-download-IANA-PEN-data.patch \ |
Brad Bishop | 1a4b7ee | 2018-12-16 17:11:34 -0800 | [diff] [blame] | 28 | " |
Andrew Geissler | 87f5cff | 2022-09-30 13:13:31 -0500 | [diff] [blame] | 29 | IANA_ENTERPRISE_NUMBERS ?= "" |
| 30 | |
| 31 | # Add these via bbappend if this database is needed by the system |
Andrew Geissler | 3eeda90 | 2023-05-19 10:14:02 -0500 | [diff] [blame] | 32 | #IANA_ENTERPRISE_NUMBERS = "http://www.iana.org/assignments/enterprise-numbers.txt;name=iana-enterprise-numbers;downloadfilename=iana-enterprise-numbers" |
Andrew Geissler | 87f5cff | 2022-09-30 13:13:31 -0500 | [diff] [blame] | 33 | #SRC_URI[iana-enterprise-numbers.sha256sum] = "cdd97fc08325667434b805eb589104ae63f7a9eb720ecea73cb55110b383934c" |
| 34 | |
| 35 | S = "${WORKDIR}/git" |
Brad Bishop | 6e60e8b | 2018-02-01 10:27:11 -0500 | [diff] [blame] | 36 | |
| 37 | inherit autotools |
| 38 | |
Andrew Geissler | 87f5cff | 2022-09-30 13:13:31 -0500 | [diff] [blame] | 39 | do_install:append() { |
| 40 | if [ -e ${WORKDIR}/iana-enterprise-numbers ]; then |
| 41 | install -Dm 0755 ${WORKDIR}/iana-enterprise-numbers ${D}${datadir}/misc/enterprise-numbers |
| 42 | fi |
| 43 | } |
| 44 | |
Andrew Geissler | 595f630 | 2022-01-24 19:11:47 +0000 | [diff] [blame] | 45 | PACKAGES =+ "${PN}-ipmievd" |
| 46 | FILES:${PN}-ipmievd += "${sbindir}/ipmievd" |
Andrew Geissler | 87f5cff | 2022-09-30 13:13:31 -0500 | [diff] [blame] | 47 | FILES:${PN} += "${datadir}/misc" |
Andrew Geissler | 595f630 | 2022-01-24 19:11:47 +0000 | [diff] [blame] | 48 | |
Brad Bishop | 6e60e8b | 2018-02-01 10:27:11 -0500 | [diff] [blame] | 49 | # --disable-dependency-tracking speeds up the build |
| 50 | # --enable-file-security adds some security checks |
| 51 | # --disable-intf-free disables FreeIPMI support - we don't want to depend on |
| 52 | # FreeIPMI libraries, FreeIPMI has its own ipmitoool-like utility. |
| 53 | # |
| 54 | EXTRA_OECONF = "--disable-dependency-tracking --enable-file-security --disable-intf-free" |