Patrick Williams | ddad1a1 | 2017-02-23 20:36:32 -0600 | [diff] [blame] | 1 | SUMMARY = "Common files and packaging infrastructure for CT-API modules" |
| 2 | HOMEPAGE = "http://fedoraproject.org/" |
| 3 | SECTION = "System Environment/Libraries" |
| 4 | LICENSE = "MIT" |
| 5 | LIC_FILES_CHKSUM = "file://../ctapi-common.LICENSE;md5=8744cd52545ecb45befebd0da6f70f0a" |
| 6 | |
Andrew Geissler | 028142b | 2023-05-05 11:29:21 -0500 | [diff] [blame] | 7 | SRC_URI = "https://distrib-coffee.ipsl.jussieu.fr/pub/linux/altlinux/autoimports/Sisyphus/x86_64/SRPMS.autoimports/ctapi-common-1.1-alt1_14.src.rpm;extract=ctapi-common.LICENSE \ |
| 8 | https://distrib-coffee.ipsl.jussieu.fr/pub/linux/altlinux/autoimports/Sisyphus/x86_64/SRPMS.autoimports/ctapi-common-1.1-alt1_14.src.rpm;extract=ctapi-common.README" |
| 9 | SRC_URI[sha256sum] = "0531a6db39271166f1e9060f81a0b2d47f878210dfb4f465c703fe205cc3a8ce" |
Patrick Williams | ddad1a1 | 2017-02-23 20:36:32 -0600 | [diff] [blame] | 10 | |
| 11 | do_compile() { |
| 12 | install -pm 644 ${WORKDIR}/ctapi-common.LICENSE LICENSE |
| 13 | install -pm 644 ${WORKDIR}/ctapi-common.README README |
| 14 | echo ${libdir}/ctapi > ctapi.conf |
| 15 | } |
| 16 | |
| 17 | do_install() { |
| 18 | install -Dpm 644 ctapi.conf ${D}${sysconfdir}/ld.so.conf.d/ctapi-${TARGET_ARCH}.conf |
| 19 | install -dm 755 ${D}${libdir}/ctapi |
| 20 | } |
| 21 | |
Patrick Williams | 213cb26 | 2021-08-07 19:21:33 -0500 | [diff] [blame] | 22 | FILES:${PN} += "${libdir}/ctapi" |