Deepak Kodihalli | 48be0fd | 2017-02-20 04:55:20 -0600 | [diff] [blame] | 1 | SUMMARY = "FRU properties config for ipmi-fru-parser" |
Brad Bishop | 75f0387 | 2018-11-03 09:41:57 -0700 | [diff] [blame] | 2 | LICENSE = "Apache-2.0" |
Brad Bishop | 6f3f0aa | 2019-09-13 12:14:05 -0400 | [diff] [blame] | 3 | LIC_FILES_CHKSUM = "file://${COREBASE}/meta/files/common-licenses/Apache-2.0;md5=89aea4e17d99a7cacdbeed46a0096b10" |
Ed Tanous | 9936f86 | 2022-09-19 09:13:20 -0700 | [diff] [blame] | 4 | PROVIDES += "virtual/phosphor-ipmi-fru-properties" |
| 5 | PR = "r1" |
Deepak Kodihalli | 48be0fd | 2017-02-20 04:55:20 -0600 | [diff] [blame] | 6 | |
Ratan Gupta | 338899a | 2017-03-30 14:32:02 +0530 | [diff] [blame] | 7 | SRC_URI += "file://extra-properties.yaml" |
Deepak Kodihalli | 48be0fd | 2017-02-20 04:55:20 -0600 | [diff] [blame] | 8 | |
Deepak Kodihalli | 48be0fd | 2017-02-20 04:55:20 -0600 | [diff] [blame] | 9 | S = "${WORKDIR}" |
| 10 | |
Ed Tanous | 9936f86 | 2022-09-19 09:13:20 -0700 | [diff] [blame] | 11 | inherit phosphor-ipmi-fru |
| 12 | inherit native |
| 13 | |
Deepak Kodihalli | 48be0fd | 2017-02-20 04:55:20 -0600 | [diff] [blame] | 14 | do_install() { |
| 15 | # This recipe is supposed to create an output yaml file with |
| 16 | # FRU property values extracted from the MRW. This example recipe |
| 17 | # provides a sample output file. |
Deepak Kodihalli | 48be0fd | 2017-02-20 04:55:20 -0600 | [diff] [blame] | 18 | DEST=${D}${properties_datadir} |
| 19 | install -d ${DEST} |
Ratan Gupta | 338899a | 2017-03-30 14:32:02 +0530 | [diff] [blame] | 20 | install extra-properties.yaml ${DEST} |
Deepak Kodihalli | 48be0fd | 2017-02-20 04:55:20 -0600 | [diff] [blame] | 21 | } |