Andrew Geissler | 517393d | 2023-01-13 08:55:19 -0600 | [diff] [blame] | 1 | SUMMARY = "Framework for layout and rendering of internationalized text" |
| 2 | DESCRIPTION = "Pango is a library for laying out and rendering of text, \ |
| 3 | with an emphasis on internationalization. Pango can be used anywhere \ |
| 4 | that text layout is needed, though most of the work on Pango so far has \ |
| 5 | been done in the context of the GTK+ widget toolkit. Pango forms the \ |
| 6 | core of text and font handling for GTK+-2.x." |
| 7 | HOMEPAGE = "http://www.pango.org/" |
| 8 | BUGTRACKER = "http://bugzilla.gnome.org" |
| 9 | SECTION = "libs" |
| 10 | LICENSE = "LGPL-2.0-or-later" |
| 11 | |
| 12 | LIC_FILES_CHKSUM = "file://COPYING;md5=3bf50002aefd002f49e7bb854063f7e7" |
| 13 | |
Andrew Geissler | 517393d | 2023-01-13 08:55:19 -0600 | [diff] [blame] | 14 | |
| 15 | inherit gnomebase gi-docgen ptest-gnome upstream-version-is-even gobject-introspection |
| 16 | |
| 17 | UPSTREAM_CHECK_REGEX = "pango-(?P<pver>\d+\.(?!9\d+)\d+\.\d+)" |
| 18 | |
| 19 | GIR_MESON_ENABLE_FLAG = "enabled" |
| 20 | GIR_MESON_DISABLE_FLAG = "disabled" |
| 21 | |
| 22 | SRC_URI += "file://run-ptest \ |
| 23 | file://0001-Skip-running-test-layout-test.patch \ |
| 24 | " |
| 25 | |
Andrew Geissler | 5082cc7 | 2023-09-11 08:41:39 -0400 | [diff] [blame] | 26 | SRC_URI[archive.sha256sum] = "74efc109ae6f903bbe6af77eaa2ac6094b8ee245a2e23f132a7a8f0862d1a9f5" |
Andrew Geissler | 517393d | 2023-01-13 08:55:19 -0600 | [diff] [blame] | 27 | |
| 28 | DEPENDS = "glib-2.0 glib-2.0-native fontconfig freetype virtual/libiconv cairo harfbuzz fribidi" |
| 29 | |
| 30 | PACKAGECONFIG ??= "${@bb.utils.filter('DISTRO_FEATURES', 'x11', d)} \ |
| 31 | ${@bb.utils.contains('PTEST_ENABLED', '1', 'tests', '', d)}" |
| 32 | |
| 33 | PACKAGECONFIG[x11] = ",,virtual/libx11 libxft" |
| 34 | PACKAGECONFIG[tests] = "-Dinstall-tests=true, -Dinstall-tests=false" |
Andrew Geissler | 5082cc7 | 2023-09-11 08:41:39 -0400 | [diff] [blame] | 35 | PACKAGECONFIG[thai] = "-Dlibthai=enabled,-Dlibthai=disabled,libthai" |
Andrew Geissler | 517393d | 2023-01-13 08:55:19 -0600 | [diff] [blame] | 36 | |
| 37 | GIR_MESON_OPTION = 'introspection' |
| 38 | |
| 39 | do_configure:prepend() { |
| 40 | chmod +x ${S}/tests/*.py |
| 41 | } |
| 42 | |
| 43 | LEAD_SONAME = "libpango-1.0*" |
| 44 | |
| 45 | FILES:${PN} = "${bindir}/* ${libdir}/libpango*${SOLIBS}" |
| 46 | |
| 47 | RDEPENDS:${PN}-ptest += "cantarell-fonts" |
| 48 | RDEPENDS:${PN}-ptest:append:libc-glibc = " locale-base-en-us" |
| 49 | |
| 50 | RPROVIDES:${PN} += "pango-modules pango-module-indic-lang \ |
| 51 | pango-module-basic-fc pango-module-arabic-lang" |
| 52 | |
| 53 | BBCLASSEXTEND = "native nativesdk" |